[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Various Problems With Latest PSPP Version

From: Alan Mead
Subject: Re: Various Problems With Latest PSPP Version
Date: Wed, 27 Sep 2023 13:47:08 -0400
User-agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:102.0) Gecko/20100101 Thunderbird/102.12.0


Sorry to hear you're having such problems. This looks like a serious error and you should file a bug. I don't know if your dataset is publicly available, but ideally you would include the dataset and the PSPP syntax that generated the error. If the developers cannot replicate your bug, then they cannot see what's wrong nor test their fixes.

If I had to guess, and it's just a guess, the size of your dataset may be part of the issue.

Does that C++ assertion error happen every time? I wouldn't ignore it. An assertion is code added to the program in an impossible place. Ignoring it seems like it would lead to random results, which is what you see.

Also, dumb question maybe, but does this happen always right after a fresh reboot?

Although it's always good advice to use the latest version, if you experience new bugs (as you seem to be), then it's a common practice to go back to a previous version that worked better.

In your case, I might also be tempted to calculate some of these descriptive statistics using simpler tools like a spreadsheet so you have a better idea what the reality of your dataset is.


On 9/26/2023 9:05 AM, Ricardo Mejias wrote:
At your suggestion, I upgraded to the lates version of PSPP: 1.6.2-g78a33a, on Windows.  But I also deleted my previous version, which I believe was [cid:939b582a-d8bb-457f-9894-6cb4832b4c7e] (from a previous email I sent you).  I ran some regressions and everything went fine.  But then I ran a fairly lengthy code that I have not changed since the last month I ran it, to create a report, and these very strange things happened: 
The data table showing up on the screen was filled with ??? on all cells.  Sample: 

The Output does not show any errors.
The file that was saved had the generally expected numbers on it when I opened it. 
SET FORMAT COMMA16.4                  


/VARIABLES = SelectedFields_20230912 VoterIDParty_20230808 REP DEM NPA LPF OTH Aug2023EftReg Aug2023EftDeReg Aug2023LPFEftReg Aug2023LPFEftDeReg REPtoLPF DEMtoLPF NPAtoLPF OTHtoLPF LPFtoREP LPFtoDEM LPFtoNPA LPFtoOTH Active Inactive BlankStatus ActiveLPF InactiveLPF BlankStatusLPF Aug2023EftRegAge Aug2023LPFEftRegAge Aug2023MGender Aug2023FGender Aug2023UGender Aug2023BGender Aug2023EftRegMGender Aug2023EftRegFGender Aug2023EftRegUGender Aug2023EftRegBGender Aug2023LPFEftRegMGender Aug2023LPFEftRegFGender Aug2023LPFEftRegUGender Aug2023LPFEftRegBGender 

 and got this error message floating over the Output:

I clicked Ignore

The descriptive was produced, but the numbers where completely out of line with the previous month by factors of between 0.5 and 5 times. This is voter registration data that simple does not change much from month to month.

I ran the DESCRIPTIVE again and this time the above error message did not show up, but the numbers on the DESCRIPTIVE were still wrong.

I am sure that I was using the exact same code with both PSPP versions.  You may be able to fix this.  But meanwhile, how can I get back the old version I had to be able to run this report on it?

reply via email to

[Prev in Thread] Current Thread [Next in Thread]