[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: PSPP new line issue

From: Matthias Faeth
Subject: Re: PSPP new line issue
Date: Tue, 4 Oct 2022 07:41:17 +0200

Hi Adam

Thanks for your reply. Ben promised to take a look into the flatpak rights issue but has not yet.

The new line issue is here also in the sources version, but noone else seems to have it. I wonder, because I tried it on 2 separate machines (Ubuntu + fedora).

So if it would be possible for you to pack Ben's latest version to an app image, this would help!


Adam Zammit <> schrieb am Di., 4. Okt. 2022, 05:59:
Hi Matthias,

Apologies I missed that this email was addressed to me as it was grouped with the other PSPP messages.

Have you been able to get this working?


On Wed, Sep 14, 2022 at 4:11 AM Matthias Faeth <> wrote:
Hi Ben

I installed 's latest flatpak PSPP on my fedora laptop to check out the new ctables feature.

Same issues as with my ubuntu flatpak
1. no access to other directories than /run/user/...
2. new line issue with the commands still the same (commands do not permit to be written over new line)

Anybody out there who is familiar with flatpak? I think this is a permissions issue. Please advise.

If not: Adam, would you be able to provide an appimage?
Matthias Fäth
Calle San Ramon 5
ES- 46780 Oliva
Handy DE: +49 171 98 32 175
Movile ES: +34 682 33 94 02

Am Do., 8. Sept. 2022 um 11:25 Uhr schrieb Matthias Faeth <>:
Hi Ben

today I tried to check the CR/LF issue

Opened PSPP and typed into a new window

ctables /table q1r1 +q1r2 by rec_q2.
which worked fine

but this did not work
ctables /table q1r1 +
  q1r2 by rec_q2.

this also not
ctables /table q1r1
  + q1r2 by rec_q2.

However this behaviour is not limited to Ctables

This works
 descriptives     /variables=q1r1.

this not:

I experimented with "auto syntax" "batch syntax" and "interactive syntax" but no change. BTW What is this? I do not know this because my SPSS is Version 17 and does not have this (it has auto-complete and color-coding as options).

So I installed PSPP 1.4 via apt to check if this is version specific. Same behaviour. Maybe something odd with my Ubuntu (22.04 on X11)?
I'll check that later on another PC which runs on fedora on wayland.

Enclosed the spv from 1.4 (I cannot save anything from flatpak)

Matthias Fäth
Calle San Ramon 5
ES- 46780 Oliva
Handy DE: +49 171 98 32 175
Movile ES: +34 682 33 94 02

Adam Zammit
Director of Operations
Australian Consortium for Social and Political Research Inc.
+61 3 9013 9653

reply via email to

[Prev in Thread] Current Thread [Next in Thread]