poke-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[PATCH 1/4] Rename "cmds" to "dot_cmds"


From: John Darrington
Subject: [PATCH 1/4] Rename "cmds" to "dot_cmds"
Date: Thu, 14 Nov 2019 13:26:48 +0100

        * src/pk-cmd.c (cmds): Rename to dot_cmds.
        (pk_cmd_init): Deal with the consequences.
---
 ChangeLog    | 5 +++++
 src/pk-cmd.c | 4 ++--
 2 files changed, 7 insertions(+), 2 deletions(-)

diff --git a/ChangeLog b/ChangeLog
index f1d0120..7050cd3 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,8 @@
+2019-11-13 John Darrington <address@hidden>
+
+       * src/pk-cmd.c (cmds): Rename to dot_cmds.
+       (pk_cmd_init): Deal with the consequences.
+
 2019-11-14  Jose E. Marchesi  <address@hidden>
 
        * man/Makefile.am: New file.
diff --git a/src/pk-cmd.c b/src/pk-cmd.c
index b9a27d0..5ff247e 100644
--- a/src/pk-cmd.c
+++ b/src/pk-cmd.c
@@ -55,7 +55,7 @@ extern struct pk_cmd editor_cmd; /* pk-editor.c */
 struct pk_cmd null_cmd =
   {NULL, NULL, NULL, 0, NULL, NULL};
 
-static struct pk_cmd *cmds[] =
+static struct pk_cmd *dot_cmds[] =
   {
     &file_cmd,
     &exit_cmd,
@@ -744,7 +744,7 @@ pk_cmd_exec_script (const char *filename)
 void
 pk_cmd_init (void)
 {
-  cmds_trie = pk_trie_from_cmds (cmds);
+  cmds_trie = pk_trie_from_cmds (dot_cmds);
   info_trie = pk_trie_from_cmds (info_cmds);
   help_trie = pk_trie_from_cmds (help_cmds);
   vm_trie = pk_trie_from_cmds (vm_cmds);
-- 
2.11.0




reply via email to

[Prev in Thread] Current Thread [Next in Thread]