[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Plex86-devel] Installing win2k ...

From: Yann Collete
Subject: Re: [Plex86-devel] Installing win2k ...
Date: Thu, 21 Nov 2002 14:15:10 +0100
User-agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.7) Gecko/20020208


I've tried an other technique with win 98. It may works with win NT:

- Hello,

- After a lot of tries, I succeedeed in booting windows 98. It works fine.
- First of all, I've got some screenshots, where do I send these images ?

- Here's the steps I follow:

- step 1 - It build a 500 Mo image file using bximage.
- step 2 - I launch bochs so as to boot under the windows 98 CDROM. I exit the install - process (F3 to times). I launch fdisk to set up a partition then I reboot bochs, exit - again the install process and format the image (format c:). - step 3 - I copy this image under windows (cp win.img /mnt/win/C). - step 4 - I boot under windows 98 and, using winimage ( version 5.0
-          because winimage version 6.0 doesn't work. I think we can mount raw 
image under linux
- and so doesn't have to use a shareware but, it looks like there's a bug in the kernel - (see <>). - step 5 - I copy all the windows directory in the image. I copy all the files (including system files) - in the windows root directory to the image.
- step 6 -  I format a floppy disk with system files (so as to have a bootable 
disk with system
-           to init the image) and copy (or exe I don't remember) onto 
this disk.
- step 7 - I boot under linux, launch bochs so as to boot under the floppy disk 
and have the image file mounted.
- step 8 - under the floppy disk, I do a sys c:
- step 9 -  I reboot bochs so as to boot under the disk and that's all.

- If you tried to follow a "classical" way, I took more than a day to windows 
98 to install and, during the plug
- and play detection, bochs dies.

- I think it's possible to skip the floppy disk format (step 6) if you format 
the image disk and transfert systems
- files at the same times (step 2)  (don't remember the options of format - 
maybe /S). In that case, don't forget
- to skip the copy of these files during step 5.

- Your sincerely,


Lars Segerlund wrote:


I'm getting to this point :-( ... and I have done the same procedure a couple of times now, thus trying to boot and install from the win2k cd fails here.

Does anybody have any tips ? About where to start to look ? It seem's to be a hardware emulation issue ?

 / Lars Segerlund.

[VGA  ] <INFO>  char map select: #1=0 / #2=0 (unused)


ioctl PLEX86_ACTTIMER: : Invalid argument
Shutting down plugins
[XGUI ] <INFO>  Exit.
Unmapping guest physical memory.
Unmapping monitor print buffer.
Tearing down VM
Closing VM

Plex86-devel mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]