[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [platform-testers] new snapshot available: autoconf-2.72c

From: Frederic Berat
Subject: Re: [platform-testers] new snapshot available: autoconf-2.72c
Date: Tue, 28 Mar 2023 18:12:07 +0200


Regarding EGREP, although I agree in principle this can be solved by using AS_CASE, I'd argue that the component actually required AC_PROG_EGREP. In principle, that should be enough, and requesting the user to know that internally there may be some need for "_AC_PROG_EGREP_TRADITIONAL" that it can't require for, which implies that using AS_CASE is mandatory, seems excessive.

For reference, there was a discussion about this here:


On Tue, Mar 28, 2023 at 12:22 PM Richard Purdie <> wrote:
On Tue, 2023-03-28 at 09:18 +0100, Richard Purdie wrote:
> On Tue, 2023-03-28 at 08:44 +0100, Richard Purdie wrote:
> > On Mon, 2023-03-27 at 08:38 -0700, Jim Meyering wrote:
> > > We're overdue for a new release, so here's a snapshot in preparation
> > > for that, which I want to call 2.73 (skipping 2.72).  There has never
> > > been an autoconf-2.72 release, yet `git describe` now prints 2.72c and
> > > has been printing strings like v2.72a-92-g8db00aa8 for years.
> > >
> > > If you maintain a package that uses autoconf and can make a release soon,
> > > please install this and use it to bootstrap its configs.  We'd love to
> > > expose any issues before we make the release.  I've already done that
> > > with grep-3.10, so far without incident.
> >
> > I work on Yocto Project which cross compiles Linux systems from
> > sources. We run autoreconf against most things.
> >
> > I tried the 2.72c tarball and found three things which failed.
> >
> > libarchive 3.6.2 at configure time:
> >
> > > checking for int16_t... no
> > > checking for uint16_t... no
> > > checking for uint8_t... no
> > > checking for gcc  options needed to detect all undeclared functions... cannot detect
> > > configure: error: in '/media/build/poky/build/tmp/work/x86_64-linux/libarchive-native/3.6.2-r0/build':
> > > configure: error: cannot make gcc  report undeclared builtins
> > > See 'config.log' for more details
> > > NOTE: The following config.log files may provide further information.
> > > NOTE: /media/build/poky/build/tmp/work/x86_64-linux/libarchive-native/3.6.2-r0/build/config.log

This one is caused by earlier issues in the config.log. in
libarchive uses:


which wants to use AC_EGREP_HEADER, which in turn wants to call
$EGREP_TRADITIONAL which isn't set. That causes cascades of type issues
eventaually causing compile errors.

EGREP_TRADITIONAL does look to be set earlier in the configure script
but is probably getting unset again. It may be related to:

I'm out my depth at this point.



reply via email to

[Prev in Thread] Current Thread [Next in Thread]