[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Partysip-dev] problem compiling partysip

From: Aymeric Moizard
Subject: Re: [Partysip-dev] problem compiling partysip
Date: Thu, 25 Jul 2002 18:18:15 +0200 (CEST)

You have to upgrade "nameserv.h"
On my debian system, this file comes from libc6-dev (I'm
using libc-2.2.5)

On other systems, you should probably upgrade your "bind" package.

If you can't upgrade, you can probably modify the system to
use the old way. There is already a #if in ppl/unix/ppldns.c
to avoid using NS_GET* and swith back to the obsolete methods.

You just have to replace each occurence of:
#if __OpenBSD__
by :
#if defined(__OpenBSD__) || defined(OLD_NAMESER)

and compile with this additionnal flag:


Let me know if this worked. (and tell me which system you
are running...)

On Thu, 25 Jul 2002, Ajit Kalele wrote:

> hi
> following are the errors i'm getting when i tried compiling partysip ...
> -pedantic -DUSE_TM
> -I/home/ak003380/SIPPROXY/libosip-0.8.8/ -
> DPSP_SERVER_PREFIX=\"/usr/local\" -pthread -o .libs/partysip -O -Wall
> main.o psp_conf
> ig.o psp_utils.o psp_module.o psp_plugin.o osip_ctx.o osip_msg.o
> psp_req.o psp_osip.o
>  tlp.o tlp_plugin.o imp.o imp_plugin.o uap.o uap_plugin.o slp.o
> slp_plugin.o slp_bran
> ch.o sfp.o sfp_plugin.o sfp_branch.o psp_core.o psp_core2.o psp_core3.o
> psp_core4.o p
> sp_core5.o psp_resolv.o -Wl,--export-dynamic
> -L/home/ak003380/SIPPROXY/libosip-0.8.8
> /parser -L/home/ak003380/SIPPROXY/libosip-0.8.8/fsm
> ../ppl/unix/.libs/ /home
> /ak003380/SIPPROXY/libosip-0.8.8/parser/.libs/
> /home/ak003380/SIPPROXY/libo
> sip-0.8.8/fsm/.libs/ -lnsl -ldl -lresolv -Wl,--rpath
> -Wl,/usr/local/lib
> ../ppl/unix/.libs/ undefined reference to `NS_GET16'
> ../ppl/unix/.libs/ undefined reference to `NS_GET32'
> collect2: ld returned 1 exit status
> make[2]: *** [partysip] Error 1
> make[2]: Leaving directory `/home/ak003380/SIPPROXY/partysip-0.4.5/src'
> make[1]: *** [all-recursive] Error 1
> make[1]: Leaving directory `/home/ak003380/SIPPROXY/partysip-0.4.5'
> make: *** [all-recursive-am] Error 2
> can you tell me what's causing the problem ?
> have i missed any settings ?
> Ajit
> *********************************************************
> Disclaimer
> This message (including any attachments) contains
> confidential information intended for a specific
> individual and purpose, and is protected by law.
> If you are not the intended recipient, you should
> delete this message and are hereby notified that
> any disclosure, copying, or distribution of this
> message, or the taking of any action based on it,
> is strictly prohibited.
> *********************************************************
> Visit us at
> _______________________________________________
> Partysip-dev mailing list
> address@hidden

reply via email to

[Prev in Thread] Current Thread [Next in Thread]