[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Paparazzi-devel] u-blox flashing with floss jtag

From: Bruzzlee
Subject: Re: [Paparazzi-devel] u-blox flashing with floss jtag
Date: Fri, 13 Jan 2012 01:25:13 +0100
User-agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:9.0) Gecko/20111222 Thunderbird/9.0.1

It's definitive: My RX port of the GPS is broken.
Has someone done the "GS407 USB hack"? I've read that It's possible to connect an USB cable directly to the u-blox chip. But I have to free the USB_VCC from the ground. The connection between USB_VCC and GND is somewhere on the GS407 board, but where? ;-)

If I'm able to configure the GPS through the usb port the GPS will be fully usable. I don't think the autopilot needs to send something to the GPS. (Maybe Warmstart and Coldstart - but who needs this? ;-)) Bruzzlee
On Thu Jan 12 02:00:10 2012, Bruzzlee wrote:
Hi Felix
Thx 4 the answer

I think (correct me if I'm wrong) I've already connected the gps to the jtag serial port by connecting it to the UART/COM.

I now tried the your method with the bridge (tunnel firmware).
The tunnel is ready but the orange led (RX) and the second blue led on the lisa board is blinking every second.
--> no difference.
I also tried to switch RX and TX but then, no led is blinking.

Thx Bruzzlee

Am 11.01.12 22:30, schrieb Felix Ruess:
Hi Bruzzlee,

you can use the floss jtag serial port to directly connect to the gps,
or if you don't want to make cables connect to the uart on lisa/m
while having the gps on the other uart.
Then you can flash the tunnel to the lisa (bridges uart1 and uart2).

Add this to your airframe file:
<firmware name="setup">
<target name="tunnel" board="lisa_m_1.0"/>

There is just no usb_tunnel for the stm32 based autopilots so far...

Cheers, Felix

On Wed, Jan 11, 2012 at 9:39 PM, Bruzzlee<address@hidden> wrote:
Hi all
Has someone tried/managed to flash an u-blox gps with the floss jtag chip
using u-center?
The only thing I have, is a signal on RX every second (led on floss blinking
orange and plugs on the bottom of the program blinking green)
But everything I try results in a timeout.

All hints are welcome!

btw: I can't flash through a autopilot tunnel because I have only a Lisa M
at the moment.

(Lisa M V1.0)

thx Bruzzlee

Paparazzi-devel mailing list
Paparazzi-devel mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]