paparazzi-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Paparazzi-devel] Re: Launching PPRZ under Ubuntu 10.10


From: Wolfgang Schaeper
Subject: [Paparazzi-devel] Re: Launching PPRZ under Ubuntu 10.10
Date: Sat, 27 Nov 2010 21:17:29 +0100

Dear Felix and Gareth,
Thanks for your help. Indeed, paparazzi-dev and paparazzi-arm7 were missing.
Installing these after download of source code did not help. So I re-started
from scratch: erasing the partition, unstallung Ubunto 10.10 etc. etc.
Now it's all fine!
Regards,
Wolfgang


-----Urspr√ľngliche Nachricht-----
Von: address@hidden
[mailto:address@hidden Im
Auftrag von address@hidden
Gesendet: Mittwoch, 24. November 2010 22:38
An: address@hidden
Betreff: Paparazzi-devel Digest, Vol 80, Issue 50

Send Paparazzi-devel mailing list submissions to
        address@hidden

To subscribe or unsubscribe via the World Wide Web, visit
        http://lists.nongnu.org/mailman/listinfo/paparazzi-devel
or, via email, send a message with subject or body 'help' to
        address@hidden

You can reach the person managing the list at
        address@hidden

When replying, please edit your Subject line so it is more specific
than "Re: Contents of Paparazzi-devel digest..."


Today's Topics:

   1. Re: a small bug in GCS (Gautier Hattenberger)
   2. Launching PPRZ under Ubuntu 10.10 (Wolfgang Schaeper)
   3. Re: Launching PPRZ under Ubuntu 10.10 (Felix Ruess)
   4. Re: Launching PPRZ under Ubuntu 10.10 (Gareth Roberts)
   5. Re: Launching PPRZ under Ubuntu 10.10 (Felix Ruess)
   6. Re: Launching PPRZ under Ubuntu 10.10 (Gareth Roberts)
   7. Re: Launching PPRZ under Ubuntu 10.10 (Felix Ruess)


----------------------------------------------------------------------

Message: 1
Date: Wed, 24 Nov 2010 18:24:50 +0100
From: Gautier Hattenberger <address@hidden>
Subject: Re: [Paparazzi-devel] a small bug in GCS
To: address@hidden
Message-ID: <address@hidden>
Content-Type: text/plain;       charset=ISO-8859-1;     format=flowed

Hi,

It should work now. Don't forget to define MAX_BAT_LEVEL in the BAT 
section of your airframe.

Gauiter

Le 23/11/2010 19:59, Chris a icrit :
> Hi.
> As i am not that good in the GCS code portion so is it possible to 
> have a look at the
> simulator window where the battery voltage can be set
> (/home/hendrix/paparazzi/sw/simulator/launchsitl -a CESSNA -boot -norc)?
> I use a 4 cell lipo pack but as soon as i try to adjust the voltage 
> from 16.8v which is correctly
> set as the slider's maximum the slider range is automatically  set to 
> 13v so i can't adjust the voltage to the nominal 14.8v or go any 
> higher than 13v.
> Chris
>
>
> _______________________________________________
> Paparazzi-devel mailing list
> address@hidden
> http://lists.nongnu.org/mailman/listinfo/paparazzi-devel



------------------------------

Message: 2
Date: Wed, 24 Nov 2010 18:43:11 +0100
From: "Wolfgang Schaeper" <address@hidden>
Subject: [Paparazzi-devel] Launching PPRZ under Ubuntu 10.10
To: <address@hidden>
Message-ID: <address@hidden>
Content-Type: text/plain;       charset="us-ascii"

Hi,
after 18 months of successful flying I now intend to completely update my
software.
Installation of Ubuntu 10.10 as well download of the PPRZ software from
github was fine.
But when trying to launch the PPRZ software by typing "make" only some error
massages came up:

ocamldep *.ml* > depend
/bin/sh: ocamldep: not found
make[1]: ocamlfind: Command not found
make[1]: ocamlfind: Command not found
make[1]: ocamlfind: Command not found
OC fig.ml
make[1]: ocamlc: Command not found
make[1]: *** [fig.cmo] Error 127
make: *** [lib] Error 2

I then installed ocaml-findlib and tried again. Some different messages
displayed:

Ocamlfind: Package `xml-light' not found
Ocamlfind: Package `netstring' not found
Ocamlfind: Package `pcre' not found
OC fig.ml
File "fig.ml", line 1, characters 0-1:
Error: Could not find the .cmi file for interface fig.mli.
make[1]: *** [fig.cmo] Error 2
make: *** [lib] Error 2

Has anybody encountered the same problem? Are any software packages missing?

Help is welcome!

Wolfgang




------------------------------

Message: 3
Date: Wed, 24 Nov 2010 20:06:11 +0100
From: Felix Ruess <address@hidden>
Subject: Re: [Paparazzi-devel] Launching PPRZ under Ubuntu 10.10
To: address@hidden, address@hidden
Message-ID:
        <address@hidden>
Content-Type: text/plain; charset=UTF-8

Hi Wolfgang,

I'm running maverick as well, without problems. But it could be the
case that there are some dependencies missing in the paparazzi
packages that I have installed anyway.
Just to make sure, you are using the correct repo:
http://paparazzi.enac.fr/ubuntu maverick main
and you have paparazzi-dev and paparazzi-arm7 installed?
Do you have ocaml-nox installed? Ok, that should be a dependency of
paparazzi-dev. Same goes for xml-light.

Cheers, Felix

> I then installed ocaml-findlib and tried again. Some different messages
> displayed:
>
> Ocamlfind: Package `xml-light' not found
> Ocamlfind: Package `netstring' not found
> Ocamlfind: Package `pcre' not found
> OC fig.ml
> File "fig.ml", line 1, characters 0-1:
> Error: Could not find the .cmi file for interface fig.mli.
> make[1]: *** [fig.cmo] Error 2
> make: *** [lib] Error 2
>
> Has anybody encountered the same problem? Are any software packages
missing?
>
> Help is welcome!
>
> Wolfgang
>
>
> _______________________________________________
> Paparazzi-devel mailing list
> address@hidden
> http://lists.nongnu.org/mailman/listinfo/paparazzi-devel
>



------------------------------

Message: 4
Date: Wed, 24 Nov 2010 19:54:31 -0000
From: "Gareth Roberts" <address@hidden>
Subject: Re: [Paparazzi-devel] Launching PPRZ under Ubuntu 10.10
To: address@hidden, address@hidden
Message-ID: <address@hidden>
Content-Type: text/plain; charset=iso-8859-15; format=flowed;
        delsp=yes

You need to add the correct repository to your /etc/apt/sources.list file,  
then install the paparazzi-dev package.
That package depends on all the weird and wonderful software paparazzi  
needs to build.
--G

P.S I've had problems with the maverick repository, although it may be  
fine now.  The lucid repo works fine with 10.10 (maverick).

On Wed, 24 Nov 2010 17:43:11 -0000, Wolfgang Schaeper  
<address@hidden> wrote:

> Hi,
> after 18 months of successful flying I now intend to completely update my
> software.
> Installation of Ubuntu 10.10 as well download of the PPRZ software from
> github was fine.
> But when trying to launch the PPRZ software by typing "make" only some  
> error
> massages came up:
>
> ocamldep *.ml* > depend
> /bin/sh: ocamldep: not found
> make[1]: ocamlfind: Command not found
> make[1]: ocamlfind: Command not found
> make[1]: ocamlfind: Command not found
> OC fig.ml
> make[1]: ocamlc: Command not found
> make[1]: *** [fig.cmo] Error 127
> make: *** [lib] Error 2
>
> I then installed ocaml-findlib and tried again. Some different messages
> displayed:
>
> Ocamlfind: Package `xml-light' not found
> Ocamlfind: Package `netstring' not found
> Ocamlfind: Package `pcre' not found
> OC fig.ml
> File "fig.ml", line 1, characters 0-1:
> Error: Could not find the .cmi file for interface fig.mli.
> make[1]: *** [fig.cmo] Error 2
> make: *** [lib] Error 2
>
> Has anybody encountered the same problem? Are any software packages  
> missing?
>
> Help is welcome!
>
> Wolfgang
>
>
> _______________________________________________
> Paparazzi-devel mailing list
> address@hidden
> http://lists.nongnu.org/mailman/listinfo/paparazzi-devel



------------------------------

Message: 5
Date: Wed, 24 Nov 2010 21:00:09 +0100
From: Felix Ruess <address@hidden>
Subject: Re: [Paparazzi-devel] Launching PPRZ under Ubuntu 10.10
To: address@hidden
Cc: address@hidden
Message-ID:
        <address@hidden>
Content-Type: text/plain; charset=UTF-8

There were some packages missing (or an older version) in the maverick
repo until yesterday. Should be fine now.

On Wed, Nov 24, 2010 at 8:54 PM, Gareth Roberts
<address@hidden> wrote:
> You need to add the correct repository to your /etc/apt/sources.list file,
> then install the paparazzi-dev package.
> That package depends on all the weird and wonderful software paparazzi
needs
> to build.
> --G
>
> P.S I've had problems with the maverick repository, although it may be
fine
> now. B The lucid repo works fine with 10.10 (maverick).
>
> On Wed, 24 Nov 2010 17:43:11 -0000, Wolfgang Schaeper
> <address@hidden> wrote:
>
>> Hi,
>> after 18 months of successful flying I now intend to completely update my
>> software.
>> Installation of Ubuntu 10.10 as well download of the PPRZ software from
>> github was fine.
>> But when trying to launch the PPRZ software by typing "make" only some
>> error
>> massages came up:
>>
>> ocamldep *.ml* > depend
>> /bin/sh: ocamldep: not found
>> make[1]: ocamlfind: Command not found
>> make[1]: ocamlfind: Command not found
>> make[1]: ocamlfind: Command not found
>> OC fig.ml
>> make[1]: ocamlc: Command not found
>> make[1]: *** [fig.cmo] Error 127
>> make: *** [lib] Error 2
>>
>> I then installed ocaml-findlib and tried again. Some different messages
>> displayed:
>>
>> Ocamlfind: Package `xml-light' not found
>> Ocamlfind: Package `netstring' not found
>> Ocamlfind: Package `pcre' not found
>> OC fig.ml
>> File "fig.ml", line 1, characters 0-1:
>> Error: Could not find the .cmi file for interface fig.mli.
>> make[1]: *** [fig.cmo] Error 2
>> make: *** [lib] Error 2
>>
>> Has anybody encountered the same problem? Are any software packages
>> missing?
>>
>> Help is welcome!
>>
>> Wolfgang
>>
>>
>> _______________________________________________
>> Paparazzi-devel mailing list
>> address@hidden
>> http://lists.nongnu.org/mailman/listinfo/paparazzi-devel
>
> _______________________________________________
> Paparazzi-devel mailing list
> address@hidden
> http://lists.nongnu.org/mailman/listinfo/paparazzi-devel
>



------------------------------

Message: 6
Date: Wed, 24 Nov 2010 20:41:07 -0000
From: "Gareth Roberts" <address@hidden>
Subject: Re: [Paparazzi-devel] Launching PPRZ under Ubuntu 10.10
To: address@hidden
Message-ID: <address@hidden>
Content-Type: text/plain; charset=iso-8859-15; format=flowed;
        delsp=yes

Cheers Felix, I sent that about ten minutes after Wolfgang's original  
email, but our university uses Exchange...

Also, any chance of a 64 bit build?  I've been using GCS & friends on  
Maverick 64 and it works fine, the only pain is ivy-ocaml - the makefile  
needs altering very slightly to include the -fpic flag.  I did manage to  
build a paparazzi-dev package for x86_64 though, and it wasn't that bad.
Problem is, I can't put the changes into a github fork because paparazzi  
itself is fine - it's the dependancies that are missing!

I'd be happy to test or help with the packaging - this is going to become  
more and more of a problem in the future I'd imagine?
Are there any massive technical issues I'm missing?

Cheers!
--G

On Wed, 24 Nov 2010 20:00:09 -0000, Felix Ruess <address@hidden>  
wrote:

> There were some packages missing (or an older version) in the maverick
> repo until yesterday. Should be fine now.
>
> On Wed, Nov 24, 2010 at 8:54 PM, Gareth Roberts
> <address@hidden> wrote:
>> You need to add the correct repository to your /etc/apt/sources.list  
>> file,
>> then install the paparazzi-dev package.
>> That package depends on all the weird and wonderful software paparazzi  
>> needs
>> to build.
>> --G
>>
>> P.S I've had problems with the maverick repository, although it may be  
>> fine
>> now.  The lucid repo works fine with 10.10 (maverick).
>>
>> On Wed, 24 Nov 2010 17:43:11 -0000, Wolfgang Schaeper
>> <address@hidden> wrote:
>>
>>> Hi,
>>> after 18 months of successful flying I now intend to completely update  
>>> my
>>> software.
>>> Installation of Ubuntu 10.10 as well download of the PPRZ software from
>>> github was fine.
>>> But when trying to launch the PPRZ software by typing "make" only some
>>> error
>>> massages came up:
>>>
>>> ocamldep *.ml* > depend
>>> /bin/sh: ocamldep: not found
>>> make[1]: ocamlfind: Command not found
>>> make[1]: ocamlfind: Command not found
>>> make[1]: ocamlfind: Command not found
>>> OC fig.ml
>>> make[1]: ocamlc: Command not found
>>> make[1]: *** [fig.cmo] Error 127
>>> make: *** [lib] Error 2
>>>
>>> I then installed ocaml-findlib and tried again. Some different messages
>>> displayed:
>>>
>>> Ocamlfind: Package `xml-light' not found
>>> Ocamlfind: Package `netstring' not found
>>> Ocamlfind: Package `pcre' not found
>>> OC fig.ml
>>> File "fig.ml", line 1, characters 0-1:
>>> Error: Could not find the .cmi file for interface fig.mli.
>>> make[1]: *** [fig.cmo] Error 2
>>> make: *** [lib] Error 2
>>>
>>> Has anybody encountered the same problem? Are any software packages
>>> missing?
>>>
>>> Help is welcome!
>>>
>>> Wolfgang
>>>
>>>
>>> _______________________________________________
>>> Paparazzi-devel mailing list
>>> address@hidden
>>> http://lists.nongnu.org/mailman/listinfo/paparazzi-devel
>>
>> _______________________________________________
>> Paparazzi-devel mailing list
>> address@hidden
>> http://lists.nongnu.org/mailman/listinfo/paparazzi-devel
>>
>
> _______________________________________________
> Paparazzi-devel mailing list
> address@hidden
> http://lists.nongnu.org/mailman/listinfo/paparazzi-devel



------------------------------

Message: 7
Date: Wed, 24 Nov 2010 22:37:44 +0100
From: Felix Ruess <address@hidden>
Subject: Re: [Paparazzi-devel] Launching PPRZ under Ubuntu 10.10
To: address@hidden
Message-ID:
        <address@hidden>
Content-Type: text/plain; charset=UTF-8

Hi Gareth,

Eric committed some fixes on the 19th to use the -fpic flag and some
other 64bit fixes. Not sure if that is all that is needed, I still
have an old 32bit laptop. Which dependencies are the problem?

But I'm sure Eric can shed some more light on this... thanks to his
efforts we'll probably soon have support for paparazzi on osx as well
(still some problems with some ocaml packages I think).
Maybe you could test the current code again?

Cheers, Felix

On Wed, Nov 24, 2010 at 9:41 PM, Gareth Roberts
<address@hidden> wrote:
> Cheers Felix, I sent that about ten minutes after Wolfgang's original
email,
> but our university uses Exchange...
>
> Also, any chance of a 64 bit build? B I've been using GCS & friends on
> Maverick 64 and it works fine, the only pain is ivy-ocaml - the makefile
> needs altering very slightly to include the -fpic flag. B I did manage to
> build a paparazzi-dev package for x86_64 though, and it wasn't that bad.
> Problem is, I can't put the changes into a github fork because paparazzi
> itself is fine - it's the dependancies that are missing!
>
> I'd be happy to test or help with the packaging - this is going to become
> more and more of a problem in the future I'd imagine?
> Are there any massive technical issues I'm missing?
>
> Cheers!
> --G
>
> On Wed, 24 Nov 2010 20:00:09 -0000, Felix Ruess <address@hidden>
> wrote:
>
>> There were some packages missing (or an older version) in the maverick
>> repo until yesterday. Should be fine now.
>>
>> On Wed, Nov 24, 2010 at 8:54 PM, Gareth Roberts
>> <address@hidden> wrote:
>>>
>>> You need to add the correct repository to your /etc/apt/sources.list
>>> file,
>>> then install the paparazzi-dev package.
>>> That package depends on all the weird and wonderful software paparazzi
>>> needs
>>> to build.
>>> --G
>>>
>>> P.S I've had problems with the maverick repository, although it may be
>>> fine
>>> now. B The lucid repo works fine with 10.10 (maverick).
>>>
>>> On Wed, 24 Nov 2010 17:43:11 -0000, Wolfgang Schaeper
>>> <address@hidden> wrote:
>>>
>>>> Hi,
>>>> after 18 months of successful flying I now intend to completely update
>>>> my
>>>> software.
>>>> Installation of Ubuntu 10.10 as well download of the PPRZ software from
>>>> github was fine.
>>>> But when trying to launch the PPRZ software by typing "make" only some
>>>> error
>>>> massages came up:
>>>>
>>>> ocamldep *.ml* > depend
>>>> /bin/sh: ocamldep: not found
>>>> make[1]: ocamlfind: Command not found
>>>> make[1]: ocamlfind: Command not found
>>>> make[1]: ocamlfind: Command not found
>>>> OC fig.ml
>>>> make[1]: ocamlc: Command not found
>>>> make[1]: *** [fig.cmo] Error 127
>>>> make: *** [lib] Error 2
>>>>
>>>> I then installed ocaml-findlib and tried again. Some different messages
>>>> displayed:
>>>>
>>>> Ocamlfind: Package `xml-light' not found
>>>> Ocamlfind: Package `netstring' not found
>>>> Ocamlfind: Package `pcre' not found
>>>> OC fig.ml
>>>> File "fig.ml", line 1, characters 0-1:
>>>> Error: Could not find the .cmi file for interface fig.mli.
>>>> make[1]: *** [fig.cmo] Error 2
>>>> make: *** [lib] Error 2
>>>>
>>>> Has anybody encountered the same problem? Are any software packages
>>>> missing?
>>>>
>>>> Help is welcome!
>>>>
>>>> Wolfgang
>>>>
>>>>
>>>> _______________________________________________
>>>> Paparazzi-devel mailing list
>>>> address@hidden
>>>> http://lists.nongnu.org/mailman/listinfo/paparazzi-devel
>>>
>>> _______________________________________________
>>> Paparazzi-devel mailing list
>>> address@hidden
>>> http://lists.nongnu.org/mailman/listinfo/paparazzi-devel
>>>
>>
>> _______________________________________________
>> Paparazzi-devel mailing list
>> address@hidden
>> http://lists.nongnu.org/mailman/listinfo/paparazzi-devel
>
> _______________________________________________
> Paparazzi-devel mailing list
> address@hidden
> http://lists.nongnu.org/mailman/listinfo/paparazzi-devel
>



------------------------------

_______________________________________________
Paparazzi-devel mailing list
address@hidden
http://lists.nongnu.org/mailman/listinfo/paparazzi-devel


End of Paparazzi-devel Digest, Vol 80, Issue 50
***********************************************




reply via email to

[Prev in Thread] Current Thread [Next in Thread]