[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Openvortex-dev] getting au8830 alsa to work?

From: Sean .
Subject: [Openvortex-dev] getting au8830 alsa to work?
Date: Tue, 22 Apr 2003 14:26:38 -0400

Hi, I have a Vortex 2 card (see bottom for info) and I'm trying to get the 0.9.2 ALSA drivers to work.

First, I tried the most recent patch, patch-au88x0-0.92e.bz2, which patched the sources fine, but I couldn't get it to compile (using both ./configure && make, and also cvscompile):

make  -C mpu401 modules
make[2]: Entering directory `/home/aethyr/alsa-driver-0.9.2/drivers/mpu401'
make[2]: *** No rule to make target `modules'.  Stop.
make[2]: Leaving directory `/home/aethyr/alsa-driver-0.9.2/drivers/mpu401'
make[1]: *** [_modsubdir_mpu401] Error 2
make[1]: Leaving directory `/home/aethyr/alsa-driver-0.9.2/drivers'
make: *** [compile] Error 1

Then I tried patch-au88x0-0.92d.bz2, which compiled fine. I then did "make install" and also compiled and installed alsa-lib and alsa-utils, both version 0.9.2.

I then added the following information to my modules.conf:

# ALSA portion
alias char-major-116 snd
# OSS/Free portion
alias char-major-14 soundcore

## You need to customise this section for your specific sound card(s)
## and then run `update-modules' command.
## Read alsa-driver's INSTALL file in /usr/share/doc for more info.
##  ALSA portion
alias snd-card-0 snd-au8830
##  OSS/Free portion
alias sound-slot-0 snd-card-0

# OSS/Free portion - card #1
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss

alias /dev/mixer snd-mixer-oss
alias /dev/dsp snd-pcm-oss
alias /dev/midi snd-seq-oss

# Set this to the correct number of cards.
options snd cards_limit=1

And then I ran "/etc/init.d/alsasound start"

the module seemed to start up ok,
"Starting sound driver: snd-au8830 done"

lsmod returns the following:
snd-mixer-oss          13848   1  (autoclean)
snd-seq-midi            4192   0  (unused)
snd-seq-midi-event      3528   0  [snd-seq-midi]
snd-seq                40144   0  [snd-seq-midi snd-seq-midi-event]
snd-au8830             25240   1
snd-ac97-codec         38048   0  [snd-au8830]
snd-pcm                64768   0  [snd-au8830]
snd-timer              15880   0  [snd-seq snd-pcm]
snd-mpu401-uart         3824   0  [snd-au8830]
snd-rawmidi            14688   0  [snd-seq-midi snd-mpu401-uart]
snd-seq-device          4480   0  [snd-seq-midi snd-seq snd-rawmidi]
snd 32548 0 [snd-mixer-oss snd-seq-midi snd-seq-midi-event snd-seq snd-au8830 snd-ac97-codec snd-pcm snd-timer snd-mpu401-uart snd-rawmidi snd-seq-device]
soundcore               4228   3  [snd]
NVdriver             1067424  10  (autoclean)
snd-page-alloc          5292   0  [snd-pcm]

I then used alsamixer to turn the volume up in the Master and PCM channel to 100%

However, whenever I use aplay, or even "cat /dev/urandom > /dev/dsp" I get no sound. No cracks, pops, whistles, beeps, nothing, just complete silence.

I've tried everything I can think of. The OSS drivers work fine, but I was interested in trying these new ALSA drivers.

I'm using kernel-2.4.20-ck6, which can be found here:

I tried it both with sound compiled into the kernel, and sound compiled as a module. Neither way seems to work.

Sound card info:

00:0d.0 Multimedia audio controller: Aureal Semiconductor Vortex 2 (rev fe)
        Subsystem: Diamond Multimedia Systems Monster Sound II
Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- Status: Cap+ 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Latency: 32 (1000ns min, 3000ns max), cache line size 08
        Interrupt: pin A routed to IRQ 10
        Region 0: Memory at d9100000 (32-bit, non-prefetchable) [size=256K]
        Region 1: I/O ports at d800 [size=8]
        Region 2: I/O ports at dc00 [size=8]
        Capabilities: [dc] Power Management version 1
                Flags: PMEClk- DSI+ D1- D2+ AuxCurrent=0mA 
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-

Tired of spam? Get advanced junk mail protection with MSN 8.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]