[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Octave-patch-tracker] [patch #9722] [octave forge] (image) new objects

From: Hartmut
Subject: [Octave-patch-tracker] [patch #9722] [octave forge] (image) new objects imref2d and imref3d
Date: Sat, 26 Jan 2019 14:43:23 -0500 (EST)
User-agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:64.0) Gecko/20100101 Firefox/64.0

Follow-up Comment #9, patch #9722 (project octave):

Sorry, I've only managed to have a superficial look at this new code. But
thanks already, it's quite some lines and adds a fully missing feature to

Here my comments:
* I tried to do the first example from the matlab help page on imref2d. It
works fine and gives the same results. But the final call to imshow with
"imshow(im, RA)" then throughs an error. Would it be possible to also
implement support for this think in imshow as well? (Maybe lateron?)
* I have tried to run the unit tests. (It's very good that those exist.) Most
tests in the 2d folder pass. Except the one for imref2d.m itself. There I see
a failing test:

>> test imref2d
***** test
 r = imref2d;
 assert (r.XWorldLimits, [0.5, 2.5])
 assert (r.YWorldLimits, [0.5, 2.5])
 assert (r.ImageSize, [2, 2])
 assert (r.PixelExtentInWorldX, 1)
 assert (r.PixelExtentInWorldY, 1)
 assert (r.ImageExtentInWorldX, 2)
 assert (r.ImageExtentInWorldY, 2)
 assert (r.XIntrinsicLimits, [0.5, 2.5])
 assert (r.YIntrinsicLimits, [0.5, 2.5])
 r.ImageSize = [800, 600];
 assert (r.XWorldLimits, [0.5, 2.5])
 assert (r.YWorldLimits, [0.5, 2.5])
 assert (r.ImageSize, [800, 600])
 assert (r.PixelExtentInWorldX, 0.003333, 1e-5)
 assert (r.PixelExtentInWorldY, 0.0025)
 assert (r.ImageExtentInWorldX, 2)
 assert (r.ImageExtentInWorldY, 2)
 assert (r.XIntrinsicLimits, [0.5, 600.5])
 assert (r.YIntrinsicLimits, [0.5, 800.5])
!!!!! test failed
ASSERT errors for:  assert (r.PixelExtentInWorldX,0.003333,1e-5)

  Location  |  Observed  |  Expected  |  Reason
     ()           1         0.003333     Abs err 0.99667 exceeds tol 1e-05 by

* In the 3d folder, I get only failing unit tests. Am I doing something wrong

>> test imref3d
***** error id=Octave:invalid-indexing imref3d().InvalidProperty
!!!!! error failed.
Expected id=Octave:invalid-indexing, but got <>

(My tests were done withh Octave 4.4.1 under Linux.)


Reply to this item at:


  Message sent via Savannah

reply via email to

[Prev in Thread] Current Thread [Next in Thread]