[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Octave-bug-tracker] [bug #56454] [octave forge] (io) xlswrite creates i

From: Georg Wiora
Subject: [Octave-bug-tracker] [bug #56454] [octave forge] (io) xlswrite creates invalid file when GUI is disabled or not available
Date: Wed, 12 Jun 2019 05:51:44 -0400 (EDT)
User-agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:67.0) Gecko/20100101 Firefox/67.0

Follow-up Comment #5, bug #56454 (project octave):

I found different behavior between gui and cli. My conclusion was, if the io
package is not the cause of the problem, it may be ZIP functions that it is
relying on. This is at least plausible, because it is only a missing file that
corrupts the xlsx files. Zip function is part of octave core AFAIK.

Differences I found between octave-cli.exe (executed in cmd.exe) and
octave-gui.vbs (started from windows surface):

* CLI does not know perl path (windows 7). 

After adding .../Octave/usr/bin to the windows path at least "help zip" was

Then I tried the following command:


This worked on gui and failed on cli with the following output:

octave:4> zip('test.zip',{'test.fig';'test.log'})
zip I/O error: Invalid argument

zip error: Could not create output file
error: zip: zip failed with exit status = 15
error: called from
    zip at line 75 column 5

Using the windows "where" command I found an older version of ZIP.exe
shadowing ZIP.exe inside octave installation.

After removing this problem by cleaning up my path variables the xlsx problem
still persists.

I suspected different path setup inside octave. getenv('PATH') produced nearly
the same result in cli and gui with the little difference that the GUI
delivered the shortened dos path

* GUI: C:\Octave\OCTAVE~2.0\mingw64\bin
* CLI: C:\Octave\Octave-\mingw64\bin 

and gui had prefixed the following paths to the PATH variable:
* C:\Octave\OCTAVE~2.0\mingw64\qt5\bin
* C:\Octave\OCTAVE~2.0\mingw64\bin

Finally I tried to run "octave.bat --no-gui" instead of "octave-cli.exe" and
got the same results for xlsx-test. Checking the path variables showed that
now the "...\mingw64\qt5\bin" and the "...\mingw64\bin" paths had been
prefixed to PATH variable...

Here ended my ideas where to look further...

Any hints out there?


Reply to this item at:


  Message sent via Savannah

reply via email to

[Prev in Thread] Current Thread [Next in Thread]