[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Octave-bug-tracker] [bug #55943] The pause function fails when there is

From: anonymous
Subject: [Octave-bug-tracker] [bug #55943] The pause function fails when there is no argument
Date: Sun, 17 Mar 2019 23:44:17 -0400 (EDT)
User-agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:55.0) Gecko/20100101 Firefox/55.0


                 Summary: The pause function fails when there is no argument
                 Project: GNU Octave
            Submitted by: None
            Submitted on: Mon 18 Mar 2019 03:44:16 AM UTC
                Category: None
                Severity: 3 - Normal
                Priority: 5 - Normal
              Item Group: Performance
                  Status: None
             Assigned to: None
         Originator Name: Alan S
        Originator Email: address@hidden
             Open/Closed: Open
         Discussion Lock: Any
                 Release: 5.1.0
        Operating System: Microsoft Windows



I just loaded Octave 5.1.0 into my windows 10 pc, after uninstalling the older
version. Now pause does not work when there is no argument. Example


This simple script should show y1 and then it should suspend the program until
a key is pressed. It simply does not, and it runs all the way through and
stops after y2 is displayed.

I also tried variations, such as leaving off the ";" after the pause, or a
blank argument: pause(). But if I include an argument:


Then it does work properly, pausing 5 seconds between showing y1 and y2.

This does not seem to be bug 52084. It is a much simpler situation, and it is
new in 5.1.0, at least for my installation on windows 10. The pause worked
fine on the version that I just uninstalled, and it fails on the new version.


Reply to this item at:


  Message sent via Savannah

reply via email to

[Prev in Thread] Current Thread [Next in Thread]