[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Octave-bug-tracker] [bug #55906] emf format no longer works for printin

From: Pantxo Diribarne
Subject: [Octave-bug-tracker] [bug #55906] emf format no longer works for printing
Date: Thu, 14 Mar 2019 17:20:38 -0400 (EDT)
User-agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:65.0) Gecko/20100101 Firefox/65.0

Follow-up Comment #4, bug #55906 (project octave):

@Dmitri: There is this comment in __opengl_print__.m

  if (! isempty (opts.fig2dev_binary))
    ## fig2dev is prefered for conversion to emf
    fig2dev_devices = {"pstex", "mf", "emf"};

Is there a reliable way to view an emf file on linux? I tried to import your
emf file in LibreOffice but the text looks rasterized. I also tried to go
through fig2dev after svg->pdf->fig and the text is not rasterized but closed
glyph are filled (all except 1 and 2). See attached. So fig2dev is not much
more convincing than pstoedit at producing emf files.

Now the question is what made this conversion chain stop working recently on
Windows and probably long ago on linux (I checked both Octave 6.0 and 4.2.2
don't work on the same computer):
* Ghostscript hasn't changed between mxe-octave 4.4 and 5.1. It's been
upgraded recently but after the release.
* fig2dev has changed in between

changeset:   4863:e5acf1d94d33
user:        John Donoghue
date:        Fri Oct 19 15:37:38 2018 -0400
summary:     transfig: update to v3.2.7a

changeset:   4442:78ae68d33e61
user:        John D
date:        Thu Aug 03 14:05:13 2017 -0400
summary:     transfig: update to 3.2.6.a

... but on my platform I have v3.2.6.a, a version that used to work on Windows
with Octave 4.4. 

So I am at loss :-).


Reply to this item at:


  Message sent via Savannah

reply via email to

[Prev in Thread] Current Thread [Next in Thread]