[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Nano-devel] Comment/Uncomment feature patch

From: Mike Scalora
Subject: Re: [Nano-devel] Comment/Uncomment feature patch
Date: Tue, 17 May 2016 18:58:10 -0600

On Tue, May 17, 2016 at 10:08 AM, Mike Frysinger <address@hidden> wrote:
> On 17 May 2016 06:28, Mike Scalora wrote:
>> +if test "x$enable_comment" = xno; then
>> +    AC_DEFINE(DISABLE_COMMENT, 1, [Define this to disable the 
>> comment/uncomment functionality.])
>> +fi
> i strongly dislike "negative" knobs because it gets harder to read at a
> glance when you see things like "if !defined(DISABLE_COMMENT)".  it is
> pretty easy to invert this though into an ENABLE_COMMENT symbol.
> -mike

Are you suggesting the comment feature flag should start a new
convention by itself? Right now NANO_TINY is the only affirmative flag
and an all the other features are negative/disable flags.

It wouldn't take that much to switch to ENABLE_COMMENT but would it
make more sense to switch all the feature flags at the same time?


PS: I thought I had trademarked the hyphen-Mike signature in the early
nineties, you seem to be creating some brand confusion with "-mike"

reply via email to

[Prev in Thread] Current Thread [Next in Thread]