[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Re: [Nano-devel] [PATCH 01/10] configure: require autoconf-2.69/automake
Re: [Nano-devel] [PATCH 01/10] configure: require autoconf-2.69/automake-1.14
Mon, 18 Apr 2016 16:12:19 -0400
On 18 Apr 2016 21:27, Benno Schulenberg wrote:
> On Mon, Apr 18, 2016, at 08:17, Mike Frysinger wrote:
> > The autoconf-2.69 release was made in Apr 2012.
> > The automake-1.14 release was made in Jun 2013.
> > Update the requirements so we know we can rely on macros/features
> > available in those versions.
> > -AM_INIT_AUTOMAKE
> > +AM_INIT_AUTOMAKE([1.14])
> > -AC_PREREQ(2.61)
> > +AC_PREREQ([2.69])
> But as far as I can tell, you're not making use of any extra macros?
the issue is more that people with newer versions will start using macros
that only exist in the newer versions, but autoconf has no mechanism for
detecting that. you'd have to actually run autoconf-2.61 to figure out
which macros you were using that didn't exist in that version. so if we
have no compelling reason to support those older versions, it's easier to
just pull up the min required version to what we're actually using.
for example, we currently do not list a min version for automake. i can
show for a fact that versions <1.7 will fail at autoreconf time.
but failures can show up other ways ... at configure or make time. so do
we spend time testing older, or just pull up to a min ? imo there's no
real value in supporting versions that are many years old at this point.
so to flip it around, are there are any compelling scenarios we want to
support where the person is building from the *development git* repo and
is on a fairly old system ? these requirements do not impact any of our
releases as those all include the generated autotools (e.g. configure).
> After applying the patches and running ./autogen.sh, then
> running ./configure --disable-libmagic failed with this:
> ./configure: line 8314: syntax error near unexpected token `NCURSESW,'
> ./configure: line 8314: ` PKG_CHECK_MODULES(NCURSESW, ncursesw,'
> I did have pkg-config installed, but apparently it needs some minimum
> version? Should the configure script not test for this, instead of choking
> in a syntax error?
you need the development pkg-config package. the runtime-only package
most likely does not include the m4 file. but this is an example of not
hitting an error until you run configure, and these kind of errors (bad
preprocessing at m4 time) could just as easily be non-fatal to configure.
i've seen reports in Gentoo where you'd get an error on the output, but
configure wouldn't abort.
> Oh, during autogen, I still see some messages like these:
> Replacing file m4/lib-ld.m4 (non-gnulib code backed up in m4/lib-ld.m4~) !!
> Replacing file m4/lib-link.m4 (non-gnulib code backed up in m4/lib-link.m4~)
> Replacing file m4/lib-prefix.m4 (non-gnulib code backed up in
> m4/lib-prefix.m4~) !!
that's normal and i wouldn't worry about it.
Description: Digital signature
[Nano-devel] [PATCH 05/10] drop getdelim/getline fallback functions, Mike Frysinger, 2016/04/18
[Nano-devel] [PATCH 09/10] drop glib fallback for snprintf/vsnprintf, Mike Frysinger, 2016/04/18
[Nano-devel] [PATCH 06/10] drop isblank/iswblank fallback functions, Mike Frysinger, 2016/04/18
[Nano-devel] [PATCH 10/10] drop wchar.h/wctype.h/stdarg.h checks, Mike Frysinger, 2016/04/18
[Nano-devel] [PATCH 08/10] assume getopt_long support is always available, Mike Frysinger, 2016/04/18
[Nano-devel] [PATCH 04/10] drop various str fallback functions, Mike Frysinger, 2016/04/18