[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Nano-devel] Fix for backspace on FreeBSD

From: Lee Nelson
Subject: [Nano-devel] Fix for backspace on FreeBSD
Date: Fri, 13 Jun 2003 19:34:53 -0400


  When I upgraded to Nano 1.2.1, from 1.0.9, I noticed
that my Backspace key had turned into a delete key!

  Looking at the source, I thought found the problem 
(WinIO.c) KEY_DC was changed to call do_delete rather 
than just do the same thing the ctrl-H key does.

  However, that only fixed it for typing in the
"search" prompt, not in the actual editor.

  Since I'm stumped now, I was hoping someone
could enlighten me about:

  1. where I should look for this.

  2. What was the rationale for the change (just curious).

  For reference, my config is:

    Max OS X on the desktop
    GLTerm terminal window
    ssh to FreeBSD 4.8
    Bash 2.05a

  Note I tried switching to TERM=vt100, as suggested
in the FAQ, but that broke some other things.

  Best Regards,

    Lee Nelson

Naxos Technology

reply via email to

[Prev in Thread] Current Thread [Next in Thread]