[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Nano-devel] None

From: Nickolai Dobrynin
Subject: Re: [Nano-devel] None
Date: Sat, 15 Feb 2003 00:03:24 -0600 (CST)

Hi Chris!

I've done some more digging with both pre3 and the last stable 1.0.9. One thing
I probably should have mentioned immediately is that I am using Sun OS v
5.8, with a 'sparc' processor. Also, the window manager is IceWM, which
can be also seen in the screen shots I sent you some hours ago.

Following your advice, I just tried pre3 in the native UNIX mode, i.e.
without the XFree86 wrapper, and the result was IDENTICAL. I then tried
the stable version 1.0.9, and, oddly enough, the result was as bad (via my
first message), both in X and through the text-based clients like 'telnet'
or 'putty'. Actually, it was almost identical to what I previously described.
For instance, if I resize the X-window to a small size, 'nano 1.0.9'
exists: "window size too small for nano", and so forth. Once again, I was
installing everything in my local directory only since I have no access to

I *am* using both 'pico' 4.2 (occasionally) and Emacs 21.1.1 (all the
time), and those function perfectly in the exact same environment
(except for Emacs in the text mode, of course). In fact, this is why
I thought I better let you know there is a problem with 'nano'.

I think, XFree86 is, overall, good enough so that it doesn't disturb the
general picture, as far as the usage of the UNIX apps goes. If doesn't
work under Cygwin, it won't work otherwise too.

Furthermore, my terminal is defaulted to 'ansi', but I also tried setting
it to 'xterm' and 'vt200', and none of those made a difference.

Is there any other info I forgot? If I can blindly guess the reason, maybe
it is IceWM that causes problems? All the rest seems very common. Oh, and
the gcc version I am using is 3.2. Here is the precise configuration info:

Reading specs from /usr/local/lib/gcc-lib/sparc-sun-solaris2.8/3.2/specs
Configured with: ../configure --with-as=/usr/ccs/bin/as
--with-ld=/usr/ccs/bin/ld --disable-nls
Thread model: posix
gcc version 3.2

If it's OK to give you another suggestion, then it would be to update the
development history as regularly as possible. This would make the process
more open. I know for a fact that there are lots of people who are sick of
the UW way of doing things, and posting the regular development news would
perhaps draw more manpower into the project. This might be particularly
true because of some very small rumor spread around about a month ago that UW
has a plan to close up the source both for 'pine' and 'pico' and start
a proprietary game. Given that UW is a public school, I doubt this can
ever happen, but you never know!

One last note, and this is more on the Cygwin side. I've got version
1.1.10-1 installed in Cygwin, but every time I try to run it, it says:
"Error opening terminal: cygwin." or, with XFree86 running, "Error opening
terminal: xterm.". The last one is when I execute it from the local
XFree86 shell. The proper DOS version 1.0.9, on the other hand, runs just

Alright! Whenever possible please keep me posted if any of those problems
I've reported have been identified. This is only if the time permits...



On Fri, 14 Feb 2003, Chris Allegretta wrote:

> On Thu, Feb 13, 2003 at 11:48:19PM -0800, Nickolai Dobrynin wrote:
> > Hello!
> > 
> > First off, I run XFree86 on top of Windows 2000. I do not have the root
> > privileges, so I simply installed 'nano' at my own directory for local
> > use.
> > 
> > I have installed 1.1.99pre3 version of 'nano', and, at the very first
> > time I ran it, the picture I got looked like this: the lower side, where
> > all the keys are displayed, was missing, and the whole thing appeared on
> > the very top instead. I took a screenshot of it, please see the 
> > FirstRun.jpg file in attachment.
> > 
> > So, what do you think is the cause of this all? I haven't tried the last 
> > stable release; is it a recent bug (or bugs), or it was there for a 
> > while? It would be COOL if you could eliminate it by the next stable 
> > release since it's pretty basic, i.e. shows up immediately.
> Hi Nickolai,
>       Sorry to hear of your troubles with pre3.  I don't currently 
> have access to a Cygwin environment (I assume that's how you are running 
> X on top of Windows).  I will look at it as soon as possible, or 
> hopefully another developer with immediate access can duplicate the 
> issue.
> If you could please try version 1.0.9 and report whether it experiences 
> similar problems, it would be very helpful to us.  Could 
> you also let us know:
> Do other text based editors (vim, emacs if installed, jed) work 
> properly?
> What is your $TERM variable set to?
> > GREAT SUGGESTION: you folks would probably be much better off regularly
> > updating the homepage, which would likely attract other free software
> > people to help you out. I only accidentally realized there was a newer
> > version than 1.0.9. After all, this is what GPL and free software is for.
> I have taken your suggestion and modified the titlebar of the homepage 
> to include the most recent development release, thank you for the 
> suggestion.
> > Otherwise the work you are doing is great, even though it does seem like
> > it's very much in progress currently.
> To be honest this is the first report I've heard of people having issues 
> with display.  I'm currently running pre3 and it has no display problems 
> whatsoever under Linux or FreeBSD.  I hope this is a minor issue with 
> Cygwin which we can have solved shortly.  Thank you for the report and 
> with your assistance I think we should be able to get this fixed.
> Chris A
> -- 
> Chris Allegretta
> "Share and Enjoy" - Douglas Adams, 1952 - 2001

reply via email to

[Prev in Thread] Current Thread [Next in Thread]