[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Nano-devel] None

From: Nickolai Dobrynin
Subject: [Nano-devel] None
Date: Thu, 13 Feb 2003 23:48:19 -0800
User-agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2.1) Gecko/20021130


First off, I run XFree86 on top of Windows 2000. I do not have the root
privileges, so I simply installed 'nano' at my own directory for local

I have installed 1.1.99pre3 version of 'nano', and, at the very first
time I ran it, the picture I got looked like this: the lower side, where
all the keys are displayed, was missing, and the whole thing appeared on
the very top instead. I took a screenshot of it, please see the FirstRun.jpg file in attachment.

After I resized the window several times, 'nano' suddenly exited saying
something like "window size too small". Please refer to the screenshot
'WindowTooSmall.gif' in attachment.

Finally, when I ran 'nano' with the maximal window size possible, the
picture was still quite strange: 'MaxSize.gif'.

I tried setting the terminal variable to vt100 but that didn't help at

Some of these problem disappear when I use a non-root window, but I still can't resize it to an arbitrary size without having 'nano' exit
complaining about the window size.

I also tried 'nano' in combination with 'putty', a secure telnet client for MS Windows, see 'NanoWithPutty.gif' and MS Telnet -- 'NanoWithMSTelnet.gif'. A few things went strange too.


So, what do you think is the cause of this all? I haven't tried the last stable release; is it a recent bug (or bugs), or it was there for a while? It would be COOL if you could eliminate it by the next stable release since it's pretty basic, i.e. shows up immediately.

I think, it makes special sense to make it work on a text-based console
because this is how many people would use it when they can't access
anything but the stupid 'telnet' on Windows.

Please excuse me if the bugs I have listed are already somewhere in a
known-bugs list.

GREAT SUGGESTION: you folks would probably be much better off regularly
updating the homepage, which would likely attract other free software
people to help you out. I only accidentally realized there was a newer
version than 1.0.9. After all, this is what GPL and free software is for.

Otherwise the work you are doing is great, even though it does seem like
it's very much in progress currently.

Best Regards,

Nickolai Dobrynin

Description: Zip compressed data

reply via email to

[Prev in Thread] Current Thread [Next in Thread]