[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Nano-devel] GNU nano 1.1.12

From: David Lawrence Ramsey
Subject: Re: [Nano-devel] GNU nano 1.1.12
Date: Tue, 29 Oct 2002 07:54:28 -0800 (PST)

>(I tried temporarily switching to an
>earlier distribution using glibc < 2.2 to test it, but I
>ran into problems with drivers being too old for some of
>my hardware.)

Check that; I tried again, and this time I successfully
got Slackware 7.1 (w/glibc 2.1.3) temporarily running.

With the previously attached patch applied, autoconf and
automake upgraded to the proper (Slackware 8.1) versions,
and libintl not available, ./configure correctly detected
that nano shouldn't link with glibc for intl support,
checked for libintl, and, when it didn't find it, just
turned ENABLE_NLS off.  nano then compiled properly, but
without nls support, of course.

I compiled and installed gettext 0.11.5 afterwards, which
did add libintl to the system.  ./configure then properly
detected gettext/ngettext in libintl, and nano compiled
properly and was linked to libintl afterward.

So this at least works on my non-glibc-2.2-based system.
(I just updated the online version, but only to reword the
Changelog entry a bit, so no changes to the actual code
have been made to it.)

Sluggy.Net: The Sluggy Freelance Community!

Select your own custom email address for FREE! Get address@hidden w/No Ads, 
6MB, POP & more!

reply via email to

[Prev in Thread] Current Thread [Next in Thread]