monit-general
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Using monit with Outlook 365 SMTP servers


From: Martin Pala
Subject: Re: Using monit with Outlook 365 SMTP servers
Date: Wed, 14 May 2014 12:24:15 +0200

The problem is in the new TLS version ... there is bug in the mail delivery 
implementation which doesn't start TLS if the new TLSv1.1 or TLSv1.2 version is 
used. The problem is fixed in the development version - you can get it here:
https://bitbucket.org/tildeslash/monit/get/master.tar.gz

To compile:

        sh bootstrap
        ./configure
        make


The original TLSv1.0 works both in Monit and on Office365 side => as a 
workaround you can use "tlsv1" option instead of "tlsv11":

        set mailserver smtp.office365.com port 587
          username "address@hidden" password "abcdef"
          using tlsv1


Regards,
Martin


On 14 May 2014, at 11:00, Mehul Ved <address@hidden> wrote:

> I am trying to setup notifications from monit using Outlook 365 SMTP servers. 
> They use TLS v1.1. The relevant lines in monitrc are as follows:
> 
> set mailserver smtp.office365.com port 587
>   username "address@hidden" password "abcdef"
>   using tlsv11
> 
> but in the logs, it gives following error:
> 
> [GMT May 14 08:30:40] error    : Sendmail: Authentication failed -- no 
> supported authentication methods found
> 
> This configuration works with my email client. Am I missing out on something? 
> Is this the correct way to setup TLS v1.1, I couldn't find documentation to 
> setup TLS v1.1 for notifications.
> 
> The version of monit I'm using is
> $ monit -V
> This is Monit version 5.8‚Äč
> 
> --
> To unsubscribe:
> https://lists.nongnu.org/mailman/listinfo/monit-general




reply via email to

[Prev in Thread] Current Thread [Next in Thread]