[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: permision problem?

From: Matt Corks
Subject: Re: permision problem?
Date: Mon, 15 Jan 2007 15:26:19 -0500
User-agent: Mutt/1.5.13 (2006-08-11)

On Mon, Jan 15, 2007 at 09:43:10AM -0800, gabev wrote:
>I run the script (sylph start ) from the console , as root, and no
>errors.the email client started just fine.But when I tried to start with
>monit , (monit start sylpheed-claws ) I cached the folllowing error :
>GTK-Warning**:cannot open display : 'sylpheed-claws' failed to start . So it
>seems that the problems relies when monit calls the email client through the
>wrapper script ; I looked at the executable permissions and they all are the
>same (run as root, in this case); also in monitrc I put the condition to run
>the wrapper as uid root and gid root :
>check process sylpheed-claws with pidfile /tmp/
>   group mail
>   start program = "/usr/bin/sylph start "
>     as uid root and gid root
>   stop program = "/usr/bin/sylph stop"
>      as uid root and gid root
>Now I really got confused.

You could try running 'xhost +' to allow anyone at all to access your X
server (which of course is completely insecure, so change that back
after testing this!).  If that works, and this daemon for some reason
really does need to access your X server, you'll have to go read the
xauth(1) manpage and figure out how to authorize it do to so.

Also, maybe this program uses something in your environment that isn't
set in the script monit calls?  You could try looking at the output of
env(1), and adding or removing environment variables to the script.

 -- matt

address@hidden |
Calvin: The only skills I have the patience to learn are those that have
  no real application in life.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]