[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Unable to exec external script

From: Dragan Zubac
Subject: Re: Unable to exec external script
Date: Thu, 7 Dec 2006 12:32:07 +0100


Sure thing,here's the whole test setup:

a. application to be monitored is called (basically every second echo date command output to some /tmp/program.out file),the program itself does not set up it's own pid

b. start up script is called with start/stop switch,and it's also a wrapper around application handling pid's and stuff like that

In attachment is also :

a. monit.log file,during a couple of cycles where I changed exec action directive in monitrc command to explicitly use bash shell - filename monit.log
b. first monitrc file (before modification) - filename monitrc~
c. second monitrc file (after modification) - filename monitrc
d. script to be execute on event (changed pid in this case) which can accept optional parameter
    - filename
e. monit -vI output file - filename monit.out

During test I monitored /tmp/helo.out which is a file where goes output of external script to be execured each time a pid is changed of monitored application (,and there was nothing indicating that monit even tried to execute script on changed pid event.
I even tried to strace monit's child process after monit startup,but in logs there was no presence of
The system I'm using is SuSE v9.3,default installation.

Am I missing something or some other mistake I make ?



On 12/6/06, Martin Pala <address@hidden > wrote:

can you describe the configuration and situation where you expect the
exec to happen in more detail? Also the log output from monit verbose
mode (-v option) could be useful.


Dragan Zubac wrote:
> Hello
> I'm trying to configure monit software ver. 4.8.1,and was unable to
> configure moinit to exec some external script on certain events.Tried
> the following scenarios:
> a. exec "/path/to/script"
> b. exec "/bin/bash -c '/path/to/script' "
> also tried to strace monit while active,and turning on the debuging
> while active,but couldn't find any attempt to start this script ?
> Any clue ?
> Sincerely
> Dragan
> ------------------------------------------------------------------------
> --
> To unsubscribe:

To unsubscribe:

Description: Bourne shell script

Description: Bourne shell script

Attachment: monit.log
Description: Text Data

Attachment: monitrc~
Description: Binary data

Attachment: monitrc
Description: Binary data

Description: Bourne shell script

Attachment: monit.out
Description: Binary data

reply via email to

[Prev in Thread] Current Thread [Next in Thread]