[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Mldonkey-bugs] Segfault in

From: Germain
Subject: [Mldonkey-bugs] Segfault in
Date: Sun, 08 Dec 2013 13:38:12 +0000
User-agent: Gnus/5.1006 (Gnus v5.10.6) XEmacs/21.4 (Instant Classic, berkeley-unix)

Hi !

I am getting a segmentation fault when I boot up mldonkey.

It just started to happen and never went away, even after nuking 
the .mldonkey folder.
Once, when I rebooted, it started correctly but crashed again when I tried to 
stop/restart it.
The only thing that I remember having done is moving the downloads directories 
for files and directories.

I tried rebuilding and it didn't help.
I included what I see on a debug build in gdb.

Reading symbols from /usr/pkg/libexec/mldonkey/mlnet...done.
(gdb) run
Starting program: /usr/pkg/libexec/mldonkey/mlnet 
2013/12/08 13:11:49 [cO] Starting MLDonkey 3.1.3 ... 
2013/12/08 13:11:49 [cO] Language EN, locale ASCII, ulimit for open files 128
2013/12/08 13:11:49 [cO] raised ulimit for open files from 128 to 3404
2013/12/08 13:11:49 [cO] MLDonkey is working in /home/german/.mldonkey
2013/12/08 13:11:50 [Gettext] Loading language resource mlnet_strings.EN_ASCII
2013/12/08 13:11:50 [cO] loaded language resource file
2013/12/08 13:11:50 [DNS] Resolving [germ] ...
2013/12/08 13:11:50 [DNS] Resolving [] ...
2013/12/08 13:11:53 [DNS] Resolving [] ...

Program received signal SIGSEGV, Segmentation fault.
[Switching to LWP 1]
0x000000000099a93b in alloc_host_entry ()
(gdb) bt
#0  0x000000000099a93b in alloc_host_entry ()
#1  0x000000000099ab1c in unix_gethostbyname ()
#2  0x0000000000898b1e in camlIp__make_entry_from_name_1176 ()
    at src/utils/net/
#3  0x0000000000898ddb in camlIp__get_entry_cached_1185 ()
    at src/utils/net/
#4  0x0000000000899143 in camlIp__from_name_1198 () at src/utils/net/
#5  0x00000000005fdce2 in camlDriverMain__resolve_name_1155 ()
    at src/daemon/driver/
#6  0x00000000008f07a1 in camlList__exists_1136 () at
#7  0x00000000005ff04e in camlDriverMain__entry ()
    at src/daemon/driver/
#8  0x000000000059e5f9 in caml_startup__code_begin ()
#9  0x0000000000996aca in caml_start_program ()
#10 0x000000000096a122 in global constructors keyed to 
CryptoPP::cryptopp_assert_154 ()
Backtrace stopped: previous frame inner to this frame (corrupt stack?)

I can't see the Caml objects in gdb

When I compiled mldonkey in debug, I get the symbols for it and am able to
navitage in the Caml code.
But I don't get to navigate the innermost C functions that crashes.

I have seen a post about similar symptoms in the forum:

I couldn't register to the forum.
I just get a blank page on firefox and an `Error 500' on Internet Explorer.

Thanks !


reply via email to

[Prev in Thread] Current Thread [Next in Thread]