[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Mldonkey-bugs] [bugs #11872] "Reshare" doesn't check for removed files.

From: Amorphous
Subject: [Mldonkey-bugs] [bugs #11872] "Reshare" doesn't check for removed files.
Date: Sat, 19 Mar 2005 06:37:56 +0000
User-agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20050105 Debian/1.7.5-1

Follow-up Comment #8, bugs #11872 (project mldonkey):

---spiralvoice said on irc:
My problem happened with the file present in ./incoming/files without
touching the core except displaying upstats
the finished file 25x in upstats was with several version. Its easy to
reproduce: Search for txt files with avail>500 and size < 10kb

i tried that and the file did only appear once in sancho (even after
restarting sancho). but multiple times in output of the command upstats (some
files that i only shared even appeared multiple times. but i did already run
reshare multiple times to unshare some files successfully, these were not
displayed in sancho after it's restart anymore, but now i see they are still
in upstats). (btw. sancho has a bug where files that are not shared anymore
are still displayed in the shares tab after updating it.) seems like the code
for upstats and for the gui-upstats is a bit different.

so when unsharing a file (by removing it from the share and issuing reshare),
it seems to unshare the file for the donkey network (only one i tried), but
the file has still a swarmer and still appears in upstats, but not in the
sancho-gui (didn't try others).

savannah bug #12372 [starting downloads (that mlnet already had in it in that
session) fails until restart] seems to be related to this bug


Reply to this item at:


  Message sent via/by Savannah

reply via email to

[Prev in Thread] Current Thread [Next in Thread]