[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Mldonkey-bugs] [bugs #7808] uploaders get stuck in upload slots

From: spiralvoice
Subject: [Mldonkey-bugs] [bugs #7808] uploaders get stuck in upload slots
Date: Tue, 13 Apr 2004 15:56:05 -0400
User-agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040323

This mail is an automated notification from the bugs tracker
 of the project: mldonkey, a multi-networks file-sharing client.

[bugs #7808] Latest Modifications:

Changes by: 
                spiralvoice <address@hidden>
                Tue 04/13/04 at 19:56 (Europe/Berlin)

            What     | Removed                   | Added
          Resolution | None                      | Fixed
              Status | Open                      | Closed

------------------ Additional Follow-up Comments ----------------------------
This bug seems to be solved according to discussions on various forums with the 
already mentioned patches.

[bugs #7808] Full Item Snapshot:

URL: <>
Project: mldonkey, a multi-networks file-sharing client
Submitted by: 0
On: Fri 02/20/04 at 07:04

Category:  eDonkey-plugin
Severity:  9 - Blocker
Item Group:  Program malfunction
Resolution:  Fixed
Assigned to:  None
Status:  Closed
Release:  2.5.12
Release:  2.5.12
Platform Version:  Linux
Binaries Origin:  CVS / Self compiled
CPU type:  None

Summary:  uploaders get stuck in upload slots

Original Submission:  they dont download anything but if all slots get filled 
with them nobody can upload from me

nothing seems to shake them loose not even the nu command

though disabling dynamic_upload_lifetime seemed to help once

Follow-up Comments

Date: Tue 04/13/04 at 19:56         By: spiralvoice
This bug seems to be solved according to discussions on various forums with the 
already mentioned patches.

Date: Fri 03/12/04 at 16:50         By: spiralvoice
Please try this patch:
Discussion takes place here:

Date: Wed 03/10/04 at 16:15         By: None
Problem persists in 2.5-16 with CVS clean compiled and spiralvoce cores.

Is there any chance of making this annoyance going away, since it is a real 
showstopper for longrun cores.

Date: Sun 02/29/04 at 03:07         By: None
Yes, I have the same thing, I'm using the same release.

When I go view uploaders (via web, port 4080) here is what my table looks like 
(wider is better for viewing this): 

Total upload slots: 5 (0) | Pending slots: 211
Num     Network C       Client name                     IP address      CT      
CB      DL      UL      Filename
3017    Donkey  D   1126    
eMU     0       0       
4063    Donkey  D  1117    
eMU     0       0       
4528    Donkey  D       gonzo                    1116    
eMU     0       0       
4718    Donkey  D       See Doo                 1114    
eMU     0       0       
9812    Donkey  D       http://emule-proje... v8]   1024    
eMU     0       0       

1126 Minutes is like, 19 hours.  UL / DL is nothing.

When I first noticed this, the non-downloading clients were disconnected 
(perhaps THEY disconnected from me) within 20-30 minutes.  I checked back every 
once in a while and there were two clients that never downloaded anything.  It 
was a different 2 clients every 20-30 minutes though.   NOW there's five that 
have never transferred a single byte, clogging my slots for others for the past 
18.8 hours.  (My client's uptime is 22.4 hours right now).

Thanks to the previous poster about dynamic_upload_lifetime.

Thanks to mldonkey team members for your continued work on the best ever p2p 


I wish I could use CVS.  Still having troubles setting it up.  BUT That's what 
I deserve for mixing Stable, Testing, and Unstable Debian packages !!!   
(Different day, different headache.)

Date: Tue 02/24/04 at 23:57         By: spiralvoice
My guess is that CVS 2004/01/16 is the last version you can get from CVS 
without that bug. All releases from mid-january to end january can not be 
fetched from CVS because of some flaw in tagging the files.

Date: Tue 02/24/04 at 14:33         By: None
This problem seems to exist also in version 2.5-5, at least the compiled 
version of spiralvoice.

Date: Sun 02/22/04 at 04:49         By: None
Triend on systems with differen speed (400Mhz, 800Mhz) and different CPU 
(intel, athlon) and distribution (SuSE 8,1 and 9.0) with CVS build (each 
version starting with 2.5-6) and your spiralvoice cores up to 2.5.12. Same 
problem all over. hasnt changed since 2.5-6. Very problematic file handling. Destroy and 
such in stead of proper flag usage some people say.

However, your spiralvoice cores on win32 don't seems to show that problem so 

Date: Sat 02/21/04 at 15:34         By: None
This is due to changes made in introudced in 2.5-6. THe bug is 
predicted there already. The file handling need a big brushup in my opinion.

dynamic_upload_lifetime doesn't help at all.

Date: Fri 02/20/04 at 11:29         By: spiralvoice
Never had dynamic_upload_lifetime enabled but it happens here also.

CC List

CC Address                          | Comment
t8m                                 | 

For detailed info, follow this link:

  Message sent via/by Savannah

reply via email to

[Prev in Thread] Current Thread [Next in Thread]