[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Mldonkey-bugs] [bugs #8037] won't make due to some error in gui_console

From: spiralvoice
Subject: [Mldonkey-bugs] [bugs #8037] won't make due to some error in
Date: Fri, 26 Mar 2004 06:16:13 -0500
User-agent: Mozilla/5.0 (X11; U; Linux i686; de-AT; rv:1.6) Gecko/20040323

This mail is an automated notification from the bugs tracker
 of the project: mldonkey, a multi-networks file-sharing client.

[bugs #8037] Latest Modifications:

Changes by: 
                spiralvoice <address@hidden>
                Fri 03/26/04 at 11:16 (Europe/Berlin)

------------------ Additional Follow-up Comments ----------------------------
Please check if this bug still is in current CVS version.
You should find a tarball of current CVS in files section of
this project:

[bugs #8037] Full Item Snapshot:

URL: <>
Project: mldonkey, a multi-networks file-sharing client
Submitted by: Denis Phillips
On: Sun 03/07/04 at 05:54

Category:  GUI
Severity:  5 - Average
Item Group:  Compilation problem
Resolution:  None
Assigned to:  None
Status:  Open
Release:  2.5.12
Platform Version:  Linux
Binaries Origin:  Binary from Savannah
CPU type:  Intel x86

Summary:  won't make due to some error in

Original Submission:  I am running redhat 8.0, installed ocaml3.06 & 
lablgtk1.2.3, then got the following error when trying to make mldonkey
(i tried upgrading lablgtk to 2.2.0 as well but this didn't fix the problem)

ocamlopt.opt -inline 10    -I src/utils/cdk  -I src/daemon/chat  -I 
src/utils/lib  -I src/utils/net  -I tools  -I src/daemon/common  -I 
src/daemon/driver  -I src/utils/mp3tagui  -I src/config/unix  -I src/gtk/newgui 
 -I src/gtk/gui2  -I src/gtk/configwin  -I src/gtk/okey  -I src/gtk/gpattern  
-I icons/tux  -I +lablgtk  -I src/gtk/progress  -I src/im  -I src/im/yahoo  -I 
src/im/irc  -I src/networks/direct_connect  -I src/networks/opennap  -I 
src/networks/gnutella  -I src/networks/gnutella2  -I src/networks/fasttrack  -I 
src/networks/fileTP  -I src/networks/bittorrent  -I src/networks/donkey  -I 
src/networks/soulseek -c src/gtk/newgui/
File "src/gtk/newgui/", line 45, characters 6-11:
This expression has type
It has no method set_base
gmake: *** [src/gtk/newgui/gui_console.cmx] Error 2

If anyone can figure this one out it'd be muchly apreciated

Follow-up Comments

Date: Fri 03/26/04 at 11:16         By: spiralvoice
Please check if this bug still is in current CVS version.
You should find a tarball of current CVS in files section of
this project:

Date: Fri 03/12/04 at 16:51         By: spiralvoice
I made a patch to update Install.txt which reflects the new requirement for 

Date: Tue 03/09/04 at 01:49         By: su_blanc
maybe you should start from a clean installation instead of compiling 
ocaml-3.07pl2 over ocaml-3.06
Try 'make uninstall' or delete your directory /usr/local/lib/ocaml and all the 
*caml*/ocaml*/ocpp binaries in /usr/local/bin.
And then re-install everything.
Note that ocaml-3.06 is sufficient to build lablgtk-1.2.6
The 'newgui' requires lablgtk-1.2.6

Date: Mon 03/08/04 at 09:54         By: Damage
installed latest version of ocaml, with the 2nd patch, without a problem, then 
when it came to compiling lablgtk 1.2.6 i got the following error, and the same 
error when i tried to compile other versions of lablgtk:

ocamlmktop  -thread -o lablgtktop_t unix.cma threads.cma unix.cma str.cma 
   -I . lablgtk.cma gtkThread.cmo gtkInit.cmo gtkThInit.cmo
Files /usr/local/lib/ocaml/threads/unix.cma(Unix)
and /usr/local/lib/ocaml/stdlib.cma(List)
make inconsistent assumptions over interface List
make[1]: *** [lablgtktop_t] Error 2
make[1]: Leaving directory `/home/Damage/lablgtk-1.2.6/src'
make: *** [all] Error 2

... any ideas on that one, these libraries don't seem to like me?

Date: Sun 03/07/04 at 15:26         By: spiralvoice
Please try current versions of Ocaml (3.07pl2) and lablgtk (1.2.6) and report 
if this solves your problem.
Here I can build newgui without problems.

For detailed info, follow this link:

  Message sent via/by Savannah

reply via email to

[Prev in Thread] Current Thread [Next in Thread]