[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Mingw-cross-env-list] Getting bash syntax error with latest GIT

From: Bernd Kosmahl
Subject: [Mingw-cross-env-list] Getting bash syntax error with latest GIT
Date: Tue, 14 Jan 2014 14:20:10 +0100

Hi list,
went for sdl2 again and did a git pull on master before. Now no package builds 
any more. Any package dies with a bash syntax error like that:

bash: -c: line 0: syntax error near unexpected token `fi'
bash: -c: line 0: `echo 
'------------------------------------------------------------'; echo '[log]     
 /home/beko/mxe-git/log/libiconv'; echo; (echo; find 
'/home/beko/mxe-git/tmp-libiconv' -name 'config.log' -print -exec cat    {} \;; 
echo; echo 'settings.mk'; cat './settings.mk'; ) >> 
'/home/beko/mxe-git/log/20140114_135005/libiconv_i686   -pc-mingw32'; exit 1; 
make: [/home/beko/mxe-git/usr/i686-pc-mingw32/installed/libiconv] Error 1 
[done]     libiconv

I tried "make clean".
I tried 'rm ./settings.mk'

I could build again going back to commit 

The trouble starts with commit 109be23726df4fde5b5ef35fcf946d4753c167e6 
(Subject: Merge branch 'master' into verbose )

My bash version is:

address@hidden:~/mxe-git$ bash --version
GNU bash, version 4.1.5(1)-release (x86_64-pc-linux-gnu)
on a Debian GNU/Linux 6.0

Do you need further information|debugoutput to fix this or are you dropping 
support for bash 4.1.5? :)

Bernd Kosmahl

reply via email to

[Prev in Thread] Current Thread [Next in Thread]