[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Maposmatic-dev] Use of Postgis 1.5

From: Maxime Petazzoni
Subject: Re: [Maposmatic-dev] Use of Postgis 1.5
Date: Fri, 5 Nov 2010 09:14:28 -0700
User-agent: Mutt/1.5.20 (2009-06-14)


* address@hidden <address@hidden> [2010-11-05 16:27:27]:

> I tried to get ocitysmap working on a Postgres 8.4 and 1.4 on Ubuntu.
> Cause it would be difficult to migrate to a new PostGIS Version (I try
> to psuh OSM for my local authorities) I would like to ask of what
> features you use that require v1.5. and if it would be possible for me
> to create a backport?

PostGIS 1.5 is required to perform properly some geographic queries that
are otherwise broken on PostGIS 1.4. It's actually GEOS 3.2 which is
required for proper geographic intersections computation, but to use
GEOS >= 3.2 you need PostGIS >= 1.5.

There should be backports of GEOS 3.2 and PostGIS 1.5 available from
Ubuntu 10.10.

- Maxime
Maxime Petazzoni <>
 ``One by one, the penguins took away my sanity.''
Linux kernel and software developer at MontaVista Software

Attachment: signature.asc
Description: Digital signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]