[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [PATCH] fix module loading (was: [PATCH] build: fix bootstrapping)

From: Pavel Raiskup
Subject: Re: [PATCH] fix module loading (was: [PATCH] build: fix bootstrapping)
Date: Sat, 22 Nov 2014 16:57:14 +0100
User-agent: KMail/4.14.2 (Linux/3.17.2-200.fc20.x86_64; KDE/4.14.2; x86_64; ; )

On Friday 21 of November 2014 09:49:45 Pavel Raiskup wrote:
> 0001-build-fix-bootstrap-fail.patch

This is OK now, thanks for fixing it in HEAD.

> 0002-modules-inclusions-fix-path-searching-issues.patch

Here I tried to reformat once more the patch against master.  Result is
attached as 0001-modules-inclusions-fix-path-searching-issues.patch. That
patch is to make the modules work at all for me.

However, thinking about it over and over again, there is something wrong.
FWIW, the KO Myung-Hun's patch [1] seems to deal with the same.

When I run ./src/m4, it fails - because, by loading of required 'm4'
module, 'm4' binary search the $PWD directory.  Because it also searches
for modules without suffix, directory 'm4' is found and dlopen() is
performed on it.

* Do we really want M4PATH (thus -I) paths use for module loading?
  It seems to me that something like M4_EXT_PATH is needed and we should
  not mix 'include' with 'load'.

* Is it desired that $PWD is used for module searching?  That seems to be
  rather security hole.

* Don't we want rather load only modules having concrete platform-default
  file extension (e.g. '*.so*' files on Linux)?

For the beginning, would anyone be willing to review/push patches for

[1] http://www.mail-archive.com/address@hidden/msg01116.html


Attachment: 0001-modules-inclusions-fix-path-searching-issues.patch
Description: Text Data

reply via email to

[Prev in Thread] Current Thread [Next in Thread]