[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Lynx-dev] compile with ncurses 6.0 segment violation

From: Thomas Seeling
Subject: [Lynx-dev] compile with ncurses 6.0 segment violation
Date: Fri, 13 Jan 2017 17:56:26 +0100
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:45.0) Gecko/20100101 Thunderbird/45.5.1


I am currently playing with a DIY linux system (LFS 7.10).
This worked fine with default settings from the LFS book for ncurses.

Then I tried to tweak some settings and Lynx started to bail out with
segment violations. I tracked with gdb to the first call to pnoutrefresh
in ncurses lib.

Backtracking my changes to the configuration showed me that
--enable-widec in ncurses configure settings caused Lynx to die.

Since I'm in Germany I'd like to use charsets which contain all of the
funny german special characters. What am I doing wrong? Is something
missing so that --enable-widec doesn't work or is this a known problem?
Or is this me completely misunderstanding what "widec" means?

What I did:
cd ~/ncurses-6.0
./configure [switches]
make clean && make && make install && ldconfig
cd ~/lynx2-8-8
./configure [switches]
make clean && make && make install

working lynx configure settings (for me) were
  --with-bzlib --with-zlib
  --disable-finger --disable-gopher
  --disable-news   --disable-wais

together with ncurses configure settings:
  --with-pkg-config --enable-pc-files --with-pc-suffix
  --with-shared --with-normal --with-cxx-shared

"Do you wanna be a legend or a passing footprint on the sands of time?"

Attachment: signature.asc
Description: OpenPGP digital signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]