[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Lynx-dev] [PATCH] compile with OpenSSL 1.1.0b; WWW/Library/Implemen

From: Taketo Kabe
Subject: Re: [Lynx-dev] [PATCH] compile with OpenSSL 1.1.0b; WWW/Library/Implementation/HTTP.c
Date: Thu, 27 Oct 2016 21:08:52 +0900
User-agent: Thunderbird (Windows/20100228)

Taketo Kabe wrote:
> I tried to compile Lynx 2.8.8rel2 with latest OpenSSL 1.1.0b, but failed with
>>> ../../../WWW/Library/Implementation/HTTP.c:723: dereferencing pointer to 
>>> incomplete type
> The code tries to access the opaque pointer->options, which seems the
> last part left of directly accessing the struct member.

The TLS version wasn't correct; I'll resubmit the patch

--- ./WWW/Library/Implementation/HTTP.c.dist    Thu Oct 27 20:10:54 2016
+++ ./WWW/Library/Implementation/HTTP.c Thu Oct 27 21:04:00 2016
@@ -720,7 +720,11 @@
 #elif SSLEAY_VERSION_NUMBER >= 0x0900
        if (!try_tls) {
-           handle->options |= SSL_OP_NO_TLSv1;
+#if OPENSSL_VERSION_NUMBER >= 0x10100000L
+           SSL_set_min_proto_version(handle, TLS1_1_VERSION);
+           SSL_set_options(handle, SSL_OP_NO_TLSv1);
 #if OPENSSL_VERSION_NUMBER >= 0x0090806fL && !defined(OPENSSL_NO_TLSEXT)
        } else {
            int ret = (int) SSL_set_tlsext_host_name(handle, ssl_host);

> lynx2.8.9dev.9 seems to emit same error.
> In 2.8.9dev9, configure relies heavily on
> POSIX shell's "case" syntax, so it wasn't practical in my environment;
> dash(1) seems essential contrary to autoconf's philosophy.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]