[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Lynx-dev] Minor XLOADIMAGE quirk

From: Patrick
Subject: Re: [Lynx-dev] Minor XLOADIMAGE quirk
Date: Sat, 19 Jul 2008 09:26:57 -0700

On Sat, 19 Jul 2008 09:56:20 -0400 (EDT)
Thomas Dickey wrote:

> On Sat, 19 Jul 2008, Paul B. Mahol wrote:
> > On 7/18/08, Patrick <address@hidden> wrote:
> >> Hi.  :-)
> >>
> >> Lynx 2.8.7dev.9 seems to have forgotten what to do with the
> >> trailing `&' on external commands, and the `>' for redirecting
> >> their output, at least where XLOADIMAGE_COMMAND is concerned.
> >> Otherwise it's pretty much awesome, as usual.
> >>
> >
> > I can't reproduce it.

And I can't explain it.  Sorry.

> It might be related to (e.g., buffer flushing, etc):
> 2001-04-01 (2.8.4dev.20)
> * implement a simple workaround for staircased messages from running xli as an
>    external viewer, with lynx_nl2crlf() function -TD

Maybe, but this behaviour is new; didn't happen in 2.8.6rel.4 .

It's still minor.  I can work around it by defining a downloader,
external URL handler or something, but now I'm curious.

What's really strange is that I can't seem to define an alternate
viewer in lynx.cfg .  I tried pointing it to a script named
lynx_view [which in turn points to gqview, right now], but it
still launches xli, even after shuffling my preferred media types,
disabling the mime.types references in lynx.cfg , changing
SUFFIX_ORDER , etc.  I even tried `make distclean' and rebuilt
it, with lynx_view defined in userdefs.h .  No dice.

Seems to be a unique problem, so where else in the source would
it explicitly point to xli?  Guess I could mess with that...

Failing that, where else might Lynx be looking for suffix-maps?  I
also have Thunar [file manager] set to open image files with xli,
so maybe they're reading from the same file or something.

Thanks again,


The software required Win95 or better, so I installed Linux.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]