[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: lynx-dev lynx2.8.5dev.8 compiling on Solaris 8

From: Brian Hostetler
Subject: Re: lynx-dev lynx2.8.5dev.8 compiling on Solaris 8
Date: Thu, 5 Sep 2002 17:03:25 -0700

That worked!
Thanks a ton for your help, Thomas. I wish I had come to this list before spending 2 days on this. I hope someone that has the same issue finds this in the archives.

On Thursday, September 5, 2002, at 04:45  PM, Thomas Dickey wrote:

On Thu, Sep 05, 2002 at 04:19:02PM -0700, Brian Hostetler wrote:
Thanks for the quick response.
I downloaded and compiled ncurses-5.2 and configured as such:
./configure --with-ssl=/usr/local/ssl --with-screen=ncurses
Worked like a charm until much later in the compile when this appeared
and killed everything...

cale\"  -I.  -I..  -Ichrtrans  -I./chrtrans  -I..  -I../src
-I../WWW/Library/Implementation    -O2 -c ./LYPrettySrc.c
gcc -I/usr/local/ssl/include -DHAVE_CONFIG_H
-DLOCALEDIR=\"/usr/local/share/locale\"  -I.  -I..  -Ichrtrans
-I./chrtrans -I.. -I../src -I../WWW/Library/Implementation -O2 -c
cd chrtrans && make tables
./makeuctb ./cp1250_uni.tbl cp1250_uni.h ./makeuctb: fatal: open failed: No such file
or directory
*** Signal 9

I don't see a line in the log for compiling/linking makeuctb. But going past that, the issue is that your libssl is a dynamic library, and apparently is not in the $LD_LIBRARY_PATH (or similar) environment path. Most stuff
on Solaris relies on being in /usr/lib, while gcc adds /usr/local/lib.
Shared libraries that aren't in one of those have to be handled specially.
Lynx's configure script could check for that, but I didn't consider it.
(The reason for that is that the underlying reason for the /usr/lib rule is that it's considered the most secure way of configuring things - putting
shared libraries in random locations is not good design).

You can work around this by setting
but it looks as if the openssl package is also flawed...

Thomas E. Dickey <address@hidden>

; To UNSUBSCRIBE: Send "unsubscribe lynx-dev" to address@hidden

; To UNSUBSCRIBE: Send "unsubscribe lynx-dev" to address@hidden

reply via email to

[Prev in Thread] Current Thread [Next in Thread]