[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

lynx-dev Lynx incompatibility with RFC 2068 HTTP 1.1 specs

From: Lieven Tomme
Subject: lynx-dev Lynx incompatibility with RFC 2068 HTTP 1.1 specs
Date: Fri, 28 Dec 2001 14:26:45 +0100

Obviously, my previous post vanished somehow...
I believe to have discovered a lynx problem.
Involved URL : (a web page to transmit SMS towards a mobile phone network)
Involved Lynx version: 2.8.5 dev 2 (15 aug 2001), running on Mandrake 8.1
According to, more precisely page 14, the following can be read:
------------ < start of quotation> -----------
name = definition
The name of a rule is simply the name itself (without any enclosing "<" and ">") and is separated from its definition by the equal "=" character. Whitespace is only significant in that indentation of continuation lines is used to indicate a rule definition that spans more than one line. Certain basic rules are in uppercase, such as SP, LWS, HT, CRLF, DIGIT, ALPHA, etc. Angle brackets are used within definitions whenever their presence will facilitate discerning the use of rule names.
Quotation marks surround literal text. Unless stated otherwise, the text is case-insensitive.
------------- <end of quotation> -------------
This RFC is all what the following is about.
I ran into the situation where posting onto the mentioned page  (english version to be found at ) resulted in trouble with lynx, without encountering problems upon using Netscape, Opera and MS Internet Explorer.
Further investigation resulted in the following data logged upon posting:
  --xnyLAaB03X Content-Disposition: form-data; name=prefix Content-Type:
  text/plain; charset=iso-8859-1 0479
  --xnyLAaB03X Content-Disposition:
  form-data; name=suffix Content-Type: text/plain; charset=iso-8859-1
  --xnyLAaB03X Content-Disposition: form-data; name=smsmessage
  Content-Type: text/plain; charset=iso-8859-1 testbericht
  Content-Disposition: form-data; name=leftchars Content-Type:
  text/plain; charset=iso-8859-1
  --xnyLAaB03X Content-Disposition:
  form-data; name=.x 0
  --xnyLAaB03X Content-Disposition: form-data;
  name=.y 0

  Content-Disposition: form-data; name="prefix"
  Content-Disposition: form-data; name="suffix"
  Content-Disposition: form-data; name="smsmessage"
  gewoon een testje
  Content-Disposition: form-data; name="submit.x"
  Content-Disposition: form-data; name="submit.y"
In my opinion, this should have to do with the specs mentioned on, page 14, since lynx seems not to use quotes for the definition fields, whereas MS IE and others do.
So, IMHO, this is something that might be corrected in lynx.
I would appreciate your comments, especially since I would love to have this problem solved.
Thank you very much for your attention. Kind regards,

reply via email to

[Prev in Thread] Current Thread [Next in Thread]