[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [lwip-users] Solved: PPP no IP address assigned

From: Michael Waeber
Subject: Re: [lwip-users] Solved: PPP no IP address assigned
Date: Thu, 02 Apr 2015 10:48:09 +0200
User-agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:31.0) Gecko/20100101 Thunderbird/31.5.0

Hello Sylvain

Many thanks for your help! Now I've managed to get an IP address
assigned. Details see below.

On 01.04.2015 21:56, Sylvain Rochet wrote:
> On Wed, Apr 01, 2015 at 05:27:41PM +0200, Michael Waeber wrote:
>> On 01.04.2015 14:02, Sylvain Rochet wrote:
>>> Looks like your lwIP timeouts are not working or you don't have enough
>>> of them, PPP needs a lot of timeouts, could you check that first ?
>> What do you exactly mean with "timeouts"? We have set NO_SYS=1, so
>> there is no such thing as OS timeout. Is the PPP part not driven by
>> the TCP main task tcp_tmr()? Do i have to call another function for
>> PPP if NO_SYS=1?
> You don't have to, tcp_tmr() should do the job.
It does not, see below.

>> I've increased MEMP_NUM_SYS_TIMEOUT from 10 to 50, but receive no
>> callback either.
> It really should retry a few seconds later, could you dig what is
> happening in IPCP (ipcp.c/fsm.c) ?
This was the crucial hint!

ipcp.c/fsm.c isn't run if no answer is received and only tcp_tmr() is

We have called the various timers tcp_tmr, etharp_tmr, ip_reass_tmr and
others from our main loop. This was OK back in pre 1.4.x time and
obviously works if only ethernet is used.

Now I've changed to call sys_check_timeouts() and now fsm_timeout() in
fsm.c is called. The IPCP request is repeated after 6.8 s. To the second
request the modem answers with a request on his part. The IP address is
assigned and the callback is called with PPPERR_NONE.

> What do you have for FSM_DEFTIMEOUT in lwipopts.h/opt.h ?
Default: 6

Kind regards

reply via email to

[Prev in Thread] Current Thread [Next in Thread]