[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[lwip-users] There is no pbuf to be allocated

From: Gavin
Subject: [lwip-users] There is no pbuf to be allocated
Date: Tue, 23 Sep 2014 01:13:30 -0700 (MST)


I got one out of pbuf issue in my application.

I rewrote echo server sample to a tcp client with raw API. My test platform
is TM4C1294XL.

In my test case, I repeated the sequence:
1. connect to server and initialize the necessary parameter.
2. some data transferred between server and client.
3. close the connection and free pbuf allocated.

It was always failed at the 13th trial, so I tried to print the log and
increased memory to verify my assumption. 

1. If I made a bigger "PBUF_POOL_SIZE", and that increased the amount of
trials, but it was still failed eventually.
2. I got the log "tivaif_receive: pbuf_alloc error" that means there is no
pbuf to be allocated.

Based on the above reason, this should be the leakage of pbuf issue.

I also tried to look at the articles in the forum and verify the different
parameter, but it still can't work.

Does anyone get idea how to fix this issue?


View this message in context: 
Sent from the lwip-users mailing list archive at Nabble.com.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]