[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[lwip-users] opening multiple sockets fails

From: Dennis Borgmann
Subject: [lwip-users] opening multiple sockets fails
Date: Wed, 19 Oct 2011 10:44:21 +0200
User-agent: Mozilla/5.0 (Windows NT 6.1; rv:7.0.1) Gecko/20110929 Thunderbird/7.0.1

Hello lwIP-users!

I am working on a small project with the AVR32UC3A-processor from Atmel. Everything's fine so far and it is really nice to see an implementation like lwIP.

I tried to run an example available within AVRStudio5, a simple tftp-Server, and within this project, I tried to open multiple sockets at a time.

The example uses lwIP-1.3.2.

It seems like lwIP does not like this. As soon as I open more than one socket, the return value of socket is negative.

Doing this won't work:

    t = socket(AF_INET, SOCK_DGRAM, 0);
    if (t < 0) {
        vParTestSetLED( 6 , pdTRUE );
    s = socket(AF_INET, SOCK_DGRAM, 0);
    if (s < 0) {
        vParTestSetLED( 7 , pdTRUE ); //grĂ¼n

The system I am working on (Atmel EVK1100) will light up LED No 7, which means, the second socket-call fails.

What might be the problem? Is there a restriction within lwIP regarding the amount of possible open sockets?

Thanks a lot for any help!


reply via email to

[Prev in Thread] Current Thread [Next in Thread]