lwip-users
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[lwip-users] [PATCH 7/7] lwip: formatting chagne to make LWIP_DEBUGF mor


From: address@hidden
Subject: [lwip-users] [PATCH 7/7] lwip: formatting chagne to make LWIP_DEBUGF more readable
Date: Fri, 21 Sep 2007 02:29:16 +0000

lwip: formatting chagne to make LWIP_DEBUGF more readable
---
 user/e7/comms/lwip/include/lwip/debug.h |   10 +++++++++-
 1 files changed, 9 insertions(+), 1 deletions(-)

diff --git a/user/e7/comms/lwip/include/lwip/debug.h 
b/user/e7/comms/lwip/include/lwip/debug.h
index 306c4d1..d46b961 100644
--- a/user/e7/comms/lwip/include/lwip/debug.h
+++ b/user/e7/comms/lwip/include/lwip/debug.h
@@ -76,7 +76,15 @@
 /** print debug message only if debug message type is enabled...
  *  AND is of correct type AND is at least LWIP_DBG_LEVEL
  */
-#define LWIP_DEBUGF(debug,x) do { if (((debug) & LWIP_DBG_ON) && ((debug) & 
LWIP_DBG_TYPES_ON) && ((s16_t)((debug) & LWIP_DBG_MASK_LEVEL) >= 
LWIP_DBG_MIN_LEVEL)) { LWIP_PLATFORM_DIAG(x); if ((debug) & LWIP_DBG_HALT) 
while(1); } } while(0)
+#define LWIP_DEBUGF(debug,x) do {                                \
+    if (((debug) & LWIP_DBG_ON) && ((debug) & LWIP_DBG_TYPES_ON) \
+        && ((s16_t)((debug) & LWIP_DBG_MASK_LEVEL) >= LWIP_DBG_MIN_LEVEL)) \
+    {                                                            \
+      LWIP_PLATFORM_DIAG(x);                                     \
+      if ((debug) & LWIP_DBG_HALT)                               \
+        while(1);                                                \
+    }                                                            \
+  } while(0)
 #else  /* LWIP_DEBUG */
 #define LWIP_DEBUGF(debug,x) 
 #endif /* LWIP_DEBUG */
-- 
1.5.2.1







reply via email to

[Prev in Thread] Current Thread [Next in Thread]