[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[lwip-users] [Lwip User] Help needed on tapif , tftp client

From: Durgaprasad Chivukula
Subject: [lwip-users] [Lwip User] Help needed on tapif , tftp client
Date: Fri, 30 Sep 2005 12:50:51 +0200

Hi Jean ,
  I wrote the tftp client application , with the help of the example you had sent me (using udo sockets ) . I also configured the bridge according to the configuration you mentioned in your messages regarding " remote tcp connection on tapif interface" . I connected the client running tapif with a bridge to other system with an ip address , and which acts as a server , the tftp daemon is from the linux system (not lwip ) the tftp client is the only one from lwip. I did not make any bridge on the server. Just assigned the ip address and bought it up.  ( I use redhat linux 2.4.20  on both sides as a client and server)
When I tried to "get " a file from the server , I observed the output using ethereal ... the server is responding to the get request and only some block of contents are able to reach the client .... that is this is the output I observed using ethereal and after some time tapif_input do no respond at all and there is no communication at all and it just hangs.
When I tried to " put " to server , the client is putting to the server , a file which has already some contents with zero contents.. and nothing is there in the file...and also the tapif_input hangs.... the same case as in "get"
Did you also observe this kind of peculiar behaviour in your case too. I dot know where the probelm exactly lies... Because there is response from the client and the server as welll , do you think is there any thing wrong with my application'??? It would be nice if I can receive your help in this case... becasue I saw that you already have the tftp on lwip working .... Please help!!!!
Also other guys , who have some pointers in my problem , please let me know ....

reply via email to

[Prev in Thread] Current Thread [Next in Thread]