[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[lwip-users] TFTP client on lwip , timeout problem

From: Durgaprasad Chivukula
Subject: [lwip-users] TFTP client on lwip , timeout problem
Date: Mon, 19 Sep 2005 19:48:52 +0200

Hi Frnds ,
  I got rid of the problem which I mentioned earlier about the ip_route function in ip.c , changed a bit of my tftp implementation. I am now facing with a peculiar problem . When I try to "get'/put" a file  from/to  a remote host  , I receive a debug message tapif_input :ARP packet  and after some time its timing out and exits.I tried to capture the output from ethreal on tap 0 interface , the tftp  RRQ/WRQ (for get &put) is sent and also the ARP reply is sent , I am seeing a partial UDP output on ethereal .Ofcourse the timeout is implemented as apart of tftp , even if I increase the
value of timeout , the result is the same , I do not see any other debug messages other than tapif_input :ARP packet , even if I trun on all the debug messages . I tried to debug the program using DDD ( Data Display Debugger of Linux , I use Linux 2.4.20-8 , lwip 1.1.0 on tap0 interface)
I received a segmentation fault in netconn_recv module of api_lib.c  , I use socket interface of lwip and trying to sort out the problem , Please give me some pointers about my problem , what might have went wrong. ??
 I saw messages on lwip , regarding tftp client on lwip ... if you guys faced this type of problem please let me know .If you already have a tftp client on lwip running please share me the ideas, so that it would be helpful for me ..Please reply me ...
If you want more information , I can send the outline of my tftp implementation using socket interface..Help!!!!!!!!!!
Durga Prasad Chivukula

reply via email to

[Prev in Thread] Current Thread [Next in Thread]