[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: RE : RE : [lwip-devel] Rename some options before 1.3.0

From: Jonathan Larmour
Subject: Re: RE : RE : [lwip-devel] Rename some options before 1.3.0
Date: Wed, 23 Jan 2008 17:22:18 +0000
User-agent: Thunderbird (X11/20070530)

Frédéric BERNON wrote:
> About LWIP_ prefix, as I said, I'm not "against", but, for 1.3.0, change
> these 3 defines is a very small modification (in number of lines
> changed), add LWIP_ would be a bigger one (so, do it - or not - is more
> for post 1.3.0).

I don't think it matters how big or small the change is - it's the fact it
changes which is what makes it difficult (or not).

Personally I'd prefer everything seen by an application when it includes an
lwIP API header to have at least well-defined prefixes - either documented
parts of the API being included, and otherwise ideally lwip/LWIP; but at
least something well-defined. Most of the API header files are ok, but they
all include opt.h and the defines there have less consistency. IMHO
breaking it is fine, but if we're going to change them at some point, then
let's just change them all once, rather than once now _and_ later.

Just my opinion.

eCosCentric Limited      http://www.eCosCentric.com/     The eCos experts
Barnwell House, Barnwell Drive, Cambridge, UK.       Tel: +44 1223 245571
Registered in England and Wales: Reg No 4422071.
------["Si fractum non sit, noli id reficere"]------       Opinions==mine

reply via email to

[Prev in Thread] Current Thread [Next in Thread]