[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE : [lwip-devel] Rename some options before 1.3.0

From: Goldschmidt Simon
Subject: RE : [lwip-devel] Rename some options before 1.3.0
Date: Wed, 23 Jan 2008 10:33:53 +0100

I also think changing defines to get things cleaner (so that people see which 
defines belong together) is a good thing and should not be delayed: especially 
when introducing new defines, we later might have to remain "backwards 
compatible"... Also, we didn't release a 1.3.0pre version as a file, everyone 
is getting it from CVS only...

On the other hand, I think it is always a good idea to have the LWIP_ prefix: 
you never know who invents other defines (we're not the only ones implementing 
AUTOIP), but nobody except us has the right to prefix their defines with LWIP_ 

I don't have a strong opinion about anything except PBUF_POOL_SIZE -> 
MEMP_NUM_PBUF_POOL (that one drove me mad a couple of times), so feel free to 
decide without me.


-----Ursprüngliche Nachricht-----
Von: address@hidden [mailto:address@hidden Im Auftrag von Frédéric BERNON
Gesendet: Mittwoch, 23. Januar 2008 10:15
An: lwip-devel
Betreff: RE : [lwip-devel] Rename some options before 1.3.0

I'm agree we should stop to change code, but I see these - minor - changes like 
a way to have something "cleaner" before release (I see that like do changes in 
comments for doxygen documentation, fix minor warnings, or perhaps reorganize 
opt.h - pbufs options near mem options, etc...).

About the LWIP_ prefix, I'm agree it's something to add for define names too 
"simple", but for "LWIP_DHCP_AUTOIP_COOP -> AUTOIP_DHCP_COOP", I don't think we 
could have a conflict with a such define name. For post 1.3.0, perhaps it could 
be something to do, but to be honest, I'm not really sure (there were only 3-4 
little problems like that since previous release, so...).

Can I ask you to change your point of view for these three names? Or perhaps we 
could wait some others comments. Of course, if you're against, I will not do 
these changes. :)

Frédéric BERNON
Chef de projet informatique
Microsoft Certified Professional
Tél. : +33 (0)4-67-87-61-10
Fax. : +33 (0)4-67-70-85-44
Email : address@hidden
Web Site : http://www.hymatom.fr
P Avant d'imprimer, penser à l'environnement

-----Message d'origine-----
De : address@hidden [mailto:address@hidden De la part de Kieran Mansley Envoyé 
: mercredi 23 janvier 2008 09:49 À : Frédéric BERNON; lwip-devel Objet : Re: 
[lwip-devel] Rename some options before 1.3.0

On Tue, 2008-01-22 at 22:49 +0100, Frédéric BERNON wrote:
> I propose to rename some options before release 1.3.0 (to get a better 
> coherency for options names ) :
> Comments ?

Probably best left till after 1.3.0 now.  In the past we've had complaints that 
defines like this don't have an "LWIP" in the name and so clash with some 
external code, so I think leaving LWIP in (for example in the last one) is a 
good idea.


lwip-devel mailing list
address@hidden http://lists.nongnu.org/mailman/listinfo/lwip-devel

reply via email to

[Prev in Thread] Current Thread [Next in Thread]