[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[lwip-devel] Symbol conflict: IP_OPTIONS

From: Rasmussen, Art N.
Subject: [lwip-devel] Symbol conflict: IP_OPTIONS
Date: Tue, 8 Jan 2008 14:47:16 -0600


The symbol IP_OPTIONS in opt.h conflicts with arpa/inet.h in the gcc library for Linux systems (actually with a file #included by inet.h).

In addition the symbol could use a more descriptive name, perhaps ALLOW_IP_OPTIONS (because its purpose is to filter packets having IP option words).

The conflict requires us to rename the tag or use a non-standard #include file to replace the standard inet.h; both choices are unpleasant.

Is there any chance of renaming IP_OPTIONS to avoid the conflict and provide a more descriptive name?

Art Rasmussen

reply via email to

[Prev in Thread] Current Thread [Next in Thread]