[Top][All Lists]
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[lwip-devel] [patch #6250] MSG_MORE flag for send
From: |
Frédéric Bernon |
Subject: |
[lwip-devel] [patch #6250] MSG_MORE flag for send |
Date: |
Tue, 30 Oct 2007 09:09:28 +0000 |
User-agent: |
Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.8.1.8) Gecko/20071008 Firefox/2.0.0.8 |
Follow-up Comment #6, patch #6250 (project lwip):
>1. For sockets.h, I changed values of MSG_*. In fact, many client
application that I port to L4 use uclibc headers which are incompatible with
sockets.h one. I already tried to remove uclibc header, but it provides some
function that are not implemented into lwip library. I saw that all libc that
I know use those values. So I think its better to reuse them ? :)
I'm not sure there is a standard for these values. If another user got the
same build problem than you, but with different values, what should we do?
Better to change them, I think we could add something like :
#if ((!defined(MSG_PEEK)) && (!defined(MSG_WAITALL)) && (!defined(MSG_OOB))
&& (!defined(MSG_DONTWAIT)))
/* Flags we can use with send and recv. */
#define MSG_PEEK 0x01 /* Peeks at an incoming message */
#define MSG_WAITALL 0x02 /* Requests that the function block until the
full amount of data requested can be returned */
#define MSG_OOB 0x04 /* Requests out-of-band data. The significance
and semantics of out-of-band data are protocol-specific */
#define MSG_DONTWAIT 0x08 /* Nonblocking i/o for this operation only */
#endif
It's already done for some others parameters. Just for my information, what
other uclibc functions used these MSG_ defined?
>2. I changed the flags in sockets.c
ok
>3. I changed the comments in tcp_out.c and api_lib.c
ok
>4. For API_FLAG_xxx, no idea too
Perhaps some others developers can suggest better names? Wait and see...
_______________________________________________________
Reply to this item at:
<http://savannah.nongnu.org/patch/?6250>
_______________________________________________
Message posté via/par Savannah
http://savannah.nongnu.org/
- [lwip-devel] [patch #6250] MSG_MORE flag for send, Marc Chaland, 2007/10/29
- [lwip-devel] [patch #6250] MSG_MORE flag for send, Frédéric Bernon, 2007/10/29
- [lwip-devel] [patch #6250] MSG_MORE flag for send, Jonathan Larmour, 2007/10/29
- [lwip-devel] [patch #6250] MSG_MORE flag for send, Marc Chaland, 2007/10/29
- [lwip-devel] [patch #6250] MSG_MORE flag for send, Frédéric Bernon, 2007/10/29
- [lwip-devel] [patch #6250] MSG_MORE flag for send, Marc Chaland, 2007/10/30
- [lwip-devel] [patch #6250] MSG_MORE flag for send,
Frédéric Bernon <=
- [lwip-devel] [patch #6250] MSG_MORE flag for send, Simon Goldschmidt, 2007/10/30
- [lwip-devel] [patch #6250] MSG_MORE flag for send, Frédéric Bernon, 2007/10/30
- [lwip-devel] [patch #6250] MSG_MORE flag for send, Marc Chaland, 2007/10/30
- [lwip-devel] [patch #6250] MSG_MORE flag for send, Frédéric Bernon, 2007/10/30
- [lwip-devel] [patch #6250] MSG_MORE flag for send, Frédéric Bernon, 2007/10/30
- [lwip-devel] [patch #6250] MSG_MORE flag for send, Jonathan Larmour, 2007/10/30
- [lwip-devel] [patch #6250] MSG_MORE flag for send, Jonathan Larmour, 2007/10/30
- [lwip-devel] [patch #6250] MSG_MORE flag for send, Frédéric Bernon, 2007/10/30
- [lwip-devel] [patch #6250] MSG_MORE flag for send, Jonathan Larmour, 2007/10/30
- [lwip-devel] [patch #6250] MSG_MORE flag for send, Marc Chaland, 2007/10/30