[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[lwip-devel] udp + udp lite: shrink code size

From: Goldschmidt Simon
Subject: [lwip-devel] udp + udp lite: shrink code size
Date: Sun, 3 Jun 2007 19:31:21 +0200

Does anyone have something against compressing udp code by combining similar code (around checksum checking / generation) and keeping the differences (checksum length, ip_proto) in local variables?

That would make the code a little smaller and easier to read.

I'll take this like always after a few days: silence == agreement :-)


reply via email to

[Prev in Thread] Current Thread [Next in Thread]