lwip-commits
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[lwip-commits] [SCM] lwIP - A Lightweight TCPIP stack branch, STABLE-2_1


From: Simon Goldschmidt
Subject: [lwip-commits] [SCM] lwIP - A Lightweight TCPIP stack branch, STABLE-2_1_x, updated. STABLE-2_1_2_RELEASE-33-g108ca15
Date: Tue, 26 Feb 2019 10:42:45 -0500 (EST)

This is an automated email from the git hooks/post-receive script. It was
generated because a ref change was pushed to the repository containing
the project "lwIP - A Lightweight TCPIP stack".

The branch, STABLE-2_1_x has been updated
       via  108ca1521e5881af1ced8c317ec686f1a5c966c7 (commit)
       via  ea2bb9cd5bd69ead648cf7db8056c830ba0c8822 (commit)
       via  e6d05db86f968955db47aa260bfac90b68f12b83 (commit)
       via  d1f920a7d1b65420f9f597f973197d5d57b8d258 (commit)
       via  fee64d7515a1b789af262d924074840acb1746e9 (commit)
       via  aad77fcacb47b6794bc168f4b144e0e59cb8810a (commit)
       via  bebf072b776c5c97214bee401ccafc31abbf917c (commit)
       via  7f53f7ced4a85e42632a19b05ee455ab933877e1 (commit)
      from  91a4d59eb4232ead071864c73ce34c706e84a88b (commit)

Those revisions listed above that are new to this repository have
not appeared on any other notification email; so we list those
revisions in full, below.

- Log -----------------------------------------------------------------
commit 108ca1521e5881af1ced8c317ec686f1a5c966c7
Author: Jacob Kroon <address@hidden>
Date:   Thu Dec 20 03:01:34 2018 +0100

    PPP, PPPoE: use service name and concentrator name
    
    Make pppoe_create() actually store the passed service name and
    concentrator name, so that they are passed in the PADI/PADR/PADS
    packets.
    
    Assume that the user application won't be freeing the strings and just
    copy the string pointers, therefore remove the mem_free() in
    pppoe_destroy().
    
    Since only the pointers are copied now, make them 'const' in
    pppoe_softc.
    
    Signed-off-by: Sylvain Rochet <address@hidden>
    (cherry picked from commit c02fea096118930d866ee1572600c7c3c9d62e63)

commit ea2bb9cd5bd69ead648cf7db8056c830ba0c8822
Author: Sylvain Rochet <address@hidden>
Date:   Tue Dec 18 22:18:42 2018 +0100

    PPP, PPPoE: remove leftover from PPPOE_SCNAME_SUPPORT support
    
    Stupid me managed to push a pending patch, remove it.
    
    Signed-off-by: Sylvain Rochet <address@hidden>
    (cherry picked from commit 48615984c78ed9ba7b0af3f4ddf8177aa7551891)

commit e6d05db86f968955db47aa260bfac90b68f12b83
Author: Jacob Kroon <address@hidden>
Date:   Tue Dec 18 22:08:03 2018 +0100

    PPP, PPPoE: fix build when PPPOE_SCNAME_SUPPORT is defined
    
    lwip/src/netif/ppp/pppoe.c:768:24: error: pointer targets in passing 
argument 1 of ‘strlen’ differ in signedness [-Werror=poin$
         l1 = (int)strlen(sc->sc_service_name);
    lwip/src/netif/ppp/pppoe.c:772:24: error: pointer targets in passing 
argument 1 of ‘strlen’ differ in signedness [-Werror=poin$
         l2 = (int)strlen(sc->sc_concentrator_name);
    
    sc->sc_service_name and sc->sc_concentrator_name are best defined as
    char* because there are passed to libc strings functions which expect
    a char*.
    
    Signed-off-by: Sylvain Rochet <address@hidden>
    (cherry picked from commit 7eab5947af4dca53b0d3306788c75bd96ebd8e13)

commit d1f920a7d1b65420f9f597f973197d5d57b8d258
Author: Sylvain Rochet <address@hidden>
Date:   Tue Dec 18 21:55:55 2018 +0100

    PPP, PPPoE: rename PPPOE_TODO to PPPOE_SCNAME_SUPPORT, prepare service name 
and concentrator support
    
    Rename PPPOE_TODO to PPPOE_SCNAME_SUPPORT because this is the only
    feature enclosed by them. Prepare for proper service name and
    concentrator name support by moving PPPOE_SCNAME_SUPPORT define to
    ppp_opts.h.
    
    Signed-off-by: Sylvain Rochet <address@hidden>
    (cherry picked from commit 96548ede2b9fcf077e579098b1db9ed397bc7032)

commit fee64d7515a1b789af262d924074840acb1746e9
Author: Simon Goldschmidt <address@hidden>
Date:   Tue Feb 26 14:48:44 2019 +0100

    udp: fix udp_bind for IPADDR_TYPE_ANY
    
    See bug #55171
    
    Signed-off-by: Simon Goldschmidt <address@hidden>
    (cherry picked from commit 752cdb1a53863ce241b1eb9e712bd223b6556360)

commit aad77fcacb47b6794bc168f4b144e0e59cb8810a
Author: Jacob Kroon <address@hidden>
Date:   Tue Jan 1 20:08:24 2019 +0100

    Fix compile of UDP unit test
    
    Fix building unit tests via contrib/ports/unix/check on Debian 9, gcc 6.3.0.
    
    Fixes:
      <snip>/ip_addr.h:105:58: error: the comparison will always evaluate as 
‘true’ for the address of ‘ip1’ will never be NULL [-Werror=address]
       #define IP_SET_TYPE(ipaddr, iptype)     do { if((ipaddr) != NULL) { 
IP_SET_TYPE_VAL(*(ipaddr),iptype); }}while(0)
    
    Signed-off-by: Jacob Kroon <address@hidden>
    (cherry picked from commit 2f098c42a7e7218a3cf6ce41cadc1aa1cfeede83)

commit bebf072b776c5c97214bee401ccafc31abbf917c
Author: Dirk Ziegelmeier <address@hidden>
Date:   Thu Dec 6 14:40:57 2018 +0100

    Fix bug #55171: Binding UDP PCB with different IP type PCBs does not work
    
    by additionally checking IP address type
    
    (cherry picked from commit 2ff0db9a9b047d1c94ddbeea010561d1b9032101)

commit 7f53f7ced4a85e42632a19b05ee455ab933877e1
Author: Dirk Ziegelmeier <address@hidden>
Date:   Thu Dec 6 14:40:20 2018 +0100

    Add testcase for bug #55171: Binding UDP PCB with different IP type PCBs 
does not work
    
    (cherry picked from commit 91037b4c287e1a124ff5801222e4b8e04050ea42)

-----------------------------------------------------------------------

Summary of changes:
 src/core/udp.c                   |   8 ++-
 src/include/netif/ppp/ppp_opts.h |   7 +++
 src/include/netif/ppp/pppoe.h    |   8 +--
 src/netif/ppp/pppoe.c            |  43 ++++++-------
 test/unit/udp/test_udp.c         | 127 ++++++++++++++++++++++++++++++++++++++-
 5 files changed, 163 insertions(+), 30 deletions(-)


hooks/post-receive
-- 
lwIP - A Lightweight TCPIP stack



reply via email to

[Prev in Thread] Current Thread [Next in Thread]