[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: ContentsPlace problem

From: Samuel Lacas
Subject: Re: ContentsPlace problem
Date: Tue, 18 Dec 2001 13:54:21 +0100

Sébastien Pierre a écrit 0.9K le Mon, Dec 17, 2001 at 03:39:01PM +0100:
# I have tried this:
# but I still get :  24,1: no @ContentsPlace precedes or follows 
# this @ContentsPlace&&foll_or_prec
# I think I have to put the @ContentsPlace somewhere, but when I 
# put it in my document body I get @ContentsPlace. Maybe somebody 
# has a working example of a custom document with a table of 
# content?


sorry for my quick and inefficient answers. Indeed, the answer is in
the User's guide, p.61: in an ordinary document, you have to put
yourself the place where the TOC must appear, with the command
@ContentsGoesHere !
If the above error message is the only one you get, it should work,
though you may need to run lout twice to get the TOC. 

The followig vorks for me:

   @SysInclude { langdefs} # language definitions
   @SysInclude { bsf} # BasicSetup package
   @SysInclude { dsf} # DocumentSetup package
   @SysInclude { docf} # Ordinary package

   @Use { @BasicSetup }

   @Use { @DocumentSetup
    @MakeContents { Yes }

   @Use { @OrdinarySetup }

   @SysDatabase @FontDef  { fontdefs }
   @SysDatabase @RefStyle { refstyle }

   @Doc @Text @Begin
   @PP Here, you have normal text.
     @Title { Glou }
   @PP Glou again
   @End @Section

   @PP And here is the table of Contents !

   @End @Text

Play it again, Sam...


reply via email to

[Prev in Thread] Current Thread [Next in Thread]