[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: problem with merged index entries

From: Albert Kinderman
Subject: Re: problem with merged index entries
Date: Thu, 09 Aug 2001 12:47:49 -0700


I have done some experimenting and have no answer for you. 
However, I think this is a bug in 3.24 that may not have existed
in earlier versions of lout.  I tried your test and several
variations of it.  None produced the second index reference.  I
was puzzled, because I have a book that has multiple references in
the index, so I know that it worked at one time (the book was
probably produced with lout 3.17).

Long story short:  I went back and reran my book with lout 3.24 -
the multiple references in the index were gone.  I then looked
more closely at the index produced by 3.17.  It too had errors,
but of a different nature.  For example, if there were references
on pages 5, 11, 29, 40, 44, and 49, the index produced

error, 5 11, 29 40 44, 49

Note the missing commas.  I first thought that perhaps the commas
were missing within single chapters, but that is not the case. 
Although 5 and 11 are in Chapter 1, 29 is in Chapter 2, and 40,
44, and 49 are in Chapter 3.

Perhaps Uwe or Jeff will have an answer after vacations are over.


Thorsten Seitz wrote:
> Hi,
> I've got a problem with merged index entries: the merging simply does not
> happen.
> The following test file reproduces the problem (I'm using lout 3.24):
> @SysInclude { book }
> @Book
> //
> @Chapter
>         @Title { Index-Test }
> @Begin
> test
> test @Index Test
> @NP
> test
> test @Index Test
> @End @Chapter
> The resulting index entry is just "Test, 1" instead of the expected "Test, 1,
> 2".
> Commenting out the first "test @Index Test" results in an index entry of
> "Test, 2", just as expected.
> The curious thing is that @Common, @Rump and @Meld do work as described with
> literals, but in the @Merge command (in @DoIndex in file dsf) the result of
> {x @Rump y} is always "", even though x seems to be "Test, 1" and y seems to
> be "Test, 2". {{Test, 1} @Rump {Test, 2}} and {{Test &"0.03fu" , 1} @Rump
> {Test &"0.03fu" , 2}} both give the expected result of "2".
> Is this a known bug or am I doing something wrong?
> Any help is greatly appreciated!
> Thanks,
> Thorsten
> --
> Thorsten Seitz
> address@hidden

Albert Kinderman      Department of Management Science
       California State University, Northridge

reply via email to

[Prev in Thread] Current Thread [Next in Thread]