[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Lout broken

From: Mark Hadfield
Subject: Lout broken
Date: Wed, 16 May 2001 11:24:54 +1200

Hello all

I would appreciate help in diagnosing a problem with my lout installation.

I installed lout-3.23 on my Windows NT system last October. I built from
source with Cygwin (a Unix/Linux environment). It was very straightforward,
requiring only some changes to the makefile's "install" target to handle the
fact that the binaries have the ".exe" extension. I used lout fairly
thoroughly around this time.

I tried to use lout the other day, on files that previously worked and got
an error like the following:

lout file "/usr/local/lib/lout/data/fontdefs.ld" (from "report" line 402,
from "all" line 4):
  787,16: fatal error: too many kerning pairs in font file
/usr/local/lib/lout/font/Ti-Rm (line 584)

(The above message results from trying to process
/usr/local/doc/lout/design/all, but a very similar message occurs on any
other file.)

Since I have made various changes to my system since last October, including
Cygwin upgrades and a change to Windows 2000, I decided to re-install lout.
I deleted all related files from /usr/local and did a fresh install of
lout-3.24. Again the installation was straightforward, but I still get the
same error.

File /usr/local/lib/lout/font/Ti-Rm exists, it is readable, it is identical
to the corresponding file in the source distribution.

When I run "lout -x" it hangs, i.e. it sits there producing no output and
using no CPU time. What is it supposed to do?

Is lout fussy about file permissions? I note that that the makefile sets
permissions on the files it installs in /usr/local. That is one area where
Cygwin may not be emulating Unix very well. All files in /usr/local/lib/lout
have permissions "-rw-r--r--"

Any other ideas?

Mark Hadfield
address@hidden  http://katipo.niwa.cri.nz/~hadfield
National Institute for Water and Atmospheric Research

reply via email to

[Prev in Thread] Current Thread [Next in Thread]