[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [lmi] [lmi-commits] master a6eb063a: Adapt to wine-7.0.1

From: Greg Chicares
Subject: Re: [lmi] [lmi-commits] master a6eb063a: Adapt to wine-7.0.1
Date: Fri, 3 Mar 2023 21:18:55 +0000
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:102.0) Gecko/20100101 Thunderbird/102.3.0

On 1/21/23 14:54, Greg Chicares wrote:
> On 1/20/23 00:43, Vadim Zeitlin wrote:
>> On Thu, 19 Jan 2023 19:29:49 -0500 (EST) Greg Chicares 
>> <gchicares@sbcglobal.net> wrote:
> [...]
>> GC>     Upgrading from
>> GC>       wine-7.0 (Debian 7.0~repack-8)
>> GC>     to
>> GC>       wine-7.0.1 (Debian 7.0.1~repack-1)
>> GC>     causes some unwanted diagnostics to appear. Filtered them out, 
>> because
>> GC>     there seems to be no safe and easy way to suppress them with 
> [...]
>>  I'm somewhat surprised that these messages happen now if they didn't
>> happen before because this typically just indicates that there is no X
>> server running and this is not something that can possibly change with a
>> Wine upgrade.
> Correct.

What Vadim said above is correct: "this typically just indicates that
there is no X server running". What I added below seems to be incorrect.

> I tried running while connected to an actual TTY, and did not
> see these messages.

...apparently because an X server was running. I do see messages like these:

008c:err:winediag:nodrv_CreateWindow Application tried to create a window, \
  but no driver could be loaded.
008c:err:winediag:nodrv_CreateWindow L"The explorer process failed to start."
008c:err:systray:initialize_systray Could not create tray window

on a corporate server where no X server runs, even when connected
to an actual TTY.

> It would seem that 'wine' expects a TTY (and diagnoses its absence)

s/TTY/X server/

> Incidentally, these messages appear only for command-line tasks,
> but not for the GUI test that is run under xvfb.

Because the correct condition is whether an X server is running.

> I just pushed a change that suppressed these messages only when '! tty -s'.

I just pushed a further change that corrects the condition.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]